Illegal Op on Windows Media Player 7 to 9 upgrade

  SDJ 11:19 31 Mar 2003
Locked

A computer running Win 98 SE, trying to run the Media Player version 9 download and the exe file unpacks but as soon as the "Windows Media Player" setup screen appears it illegal ops.

Should I uninstall version 7.1 first even though I havent had this problem on two other machines?

Should I clear the temp folder?

What should I do :-(

Thanks in advance

  Lozzy 11:22 31 Mar 2003

Firstly do the other two PC's run Win 98 as well?? and yes it would hurt to clear out the folders.

  SDJ 11:40 31 Mar 2003

Yeah they both run windows 98.
Ill try clearing the temp folder
Cheers

Any other ideas if that doesnt work? no offence lozzy its just I will be doing later where I dont have internet access and want to get as many ideas as poss :-)

  SDJ 16:12 31 Mar 2003

Tried all the above and nothing worked.

I uninstalled v7 and still couldnt install v9 so know I am going to try and reinstall v7 and if it installs I think I will leave it at that unless anyone can come up with something

Cheers

  Stuartli 17:33 31 Mar 2003

Are you downloading the correct version of Windows Media Player 9?

I didn't need to uninstall WMP7.1 to download or run Version 9 (98SE etc version, not XP); in fact some programs still use Version 6.4 on my system.

  SDJ 18:03 31 Mar 2003

Yeah I am downloading the correct one, I reinstalled wmp7.1 and that didnt want to work either:-(

Illegal op= Setup_wm invalid page fault in module MSVCRT.DLL

Every time!!

  IZZY 18:31 31 Mar 2003

SDJ...

I'm sure it said somewhere on the Download page for WMP 9 that if you didn't want it for some reason - in your case, not working, I suppose,- you had to do a System Restore and this would reinstall your previous version WMP 7. I have had a quick look but can't find the reference to that specific point.

I'll keep looking but I don't think you have S.R. Catch 22 maybe.

Regards

IZZY

  SDJ 08:31 01 Apr 2003

Thanks Izzy, sorry I didnt get back to you last night but the computer I was trying to fix didnt have internet access and my laptop battery ran out! (fifteen minutes Dell Inspiron 8000 not very good must be faulty!)

Anyway, I had loads of problems and decided to reinstall win 98 and sure enough the whole thing works fine now.

Thanks again everyone.

  IZZY 12:46 01 Apr 2003

SDJ..Hello again.

Pleased you've got it sorted. Just one further thought:

If you have WMP 7 configured to automatically check for updates (Tools; Options; Player - Daily, Weekly, Monthly) it will automatically offer the option to install. That was how I updated to WMP 9 and left Windows to get on with it.

Working fine so far with WinME.

Regards and thanks for letting us know how you resolved the problem. Wish many other would do the same rather than "disappear".

Regards, IZZY

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Artist Pete Oswald on creating relatable characters & his new book

New iMac Pro release date, UK price & specs rumours

Idées cadeaux pour geeks et tech addicts