IE7/View/Encoding/A language!

  TonyV 19:49 28 Jun 2007

When viewing my home page, (a BT derivative), in IE7 there are occasions when the language for viewing that page are not correct and some characters are not shown correctly. I have Auto Select checked, and then nearly always the Unicode (UTF-8) is checked, not that I have checked it, and it this that is giving the problem. When I change to Western European (Windows) the characters show as they were intended.

How can I ensure that what I check is maintained until I decide to change it?



  skidzy 20:23 28 Jun 2007

Change the setting to Western European (iso)

If the setting continually changes,try resetting IE7.

Tools/Internet Options/Advanced/Reset web will lose any addons etc.

Though just incase IE is your only browser,download Firefox first click here

Check this works ok before resetting IE.This way you will have a working browser.

  TonyV 20:32 28 Jun 2007

IE7 is my only browser. I have tried Firefox and have not been that pleased with it in the past and uninstalled it. (May be it is the Devil I know....!) I will, however, try what you suggest and see what happens.



  skidzy 21:01 28 Jun 2007

Tony if you cannot get along with Firefox (maybe we can help on that too) try Opera click here very good browser also.

  TonyV 21:08 28 Jun 2007

I've done the reset operation you suggested above, and have now set the language to the Windows European (ISO). I'll let it settle down now and see if it maintains it at that level. I've unchecked the Auto select, so hopefully it should now behave it self. I will keep you informed.



  TonyV 21:16 28 Jun 2007

No, it will not maintain the Windows European (ISO) language. it seems to default out to the unicode one. The resetting has had no affect whatever!!

Not quite sure what to do now short of uninstalling IE7, reverting back to IE6 and then leaving for a while and changing back again to IE7.

Will keep you informed of what, if anything, happens.



  TonyV 19:22 29 Jun 2007

Thought you might like to know that I have deleted IE7 and reverted back to IE6 and still I cannot maintain any change to the language. It will hold it for that session but will revert back to Unicode when I start a new session or when I restart my computer.


  skidzy 19:41 29 Jun 2007

Now your on IE6 Tony,try this click here does not work with IE7.

  TonyV 19:59 29 Jun 2007

Thats made it even worse!! Now, every time I view a page it has reverted back to Unicode, even on the same session. i.e. I have changed it to Auto select on Western European(ISO) and if I change the page from Help Room to Home page of PCA or my own home page, it has gone back to Unicode!


  TonyV 20:10 29 Jun 2007

I have now tried many pages and they are all the same, They have all reverted back to Unicode. I think the answer is to leave as is, and change it only if the page is missing some characters. Shame, but there it is! I must confess it must have been like it for some time because I have noticed that when looking in particular at my Home Page, the £ sign has been missing in various areas like the Soccer element when the talk is of transfer fees. The option I have then is to click View/Encoding/Western European (Windows) and this usually sorts the problem out in a very temporary mode. Nothing longterm.

I also notice that when I click Auto select, I cannot leave any of the languages unchecked. In other words, if Auto select is checked so is Unicode. I would have thought that if Auto select is checked there would be no languages checked, otherwise what does Auto select mean?.



  skidzy 21:00 29 Jun 2007

Tony i will look into your problem over the weekend,strange !

Im wondering if its something on your pc that is causing these changes.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?