IDE Problems

  tomhealy 19:46 19 Jul 2003

I have been experiencing problems with drives on my pc for a while now, with drives appearing in the bios and not in xp, new hard drive appearing to have wiped itselfd only to reappear perfectly fine a couple of days later and not being able to have more than 2 ide devices connected at the same time.

I figured that i may have damaged the motherboard when i had attached a new heatsink and fan and so replaced the mobo. I also changed the ide cables but the problems remain.

All four devices work, but only two can be used, either as master and slave on one channel or masters on both.

Anyone got any ideas what may be going on and how to fix it?

  ellas 19:55 19 Jul 2003

what mobo chipset,and are you saying both slaves are not being seen by xp,have you tried running the add hardware wizard in system properties.

try using 80 conductor cables and setting all the drives to cable select .put the masters on the end connector

  tomhealy 01:57 20 Jul 2003

what are '80 conductor' cables?

  tomhealy 02:09 20 Jul 2003

new mobo (ecs k7s5a pro) chipset is sis735

old mobo (asus a7a266e) was ALi MAGIK 1

will connect only with two devices but they can be connected as master or slave on either channel

  keith-236785 07:01 20 Jul 2003


you mention, (ecs k7s5a pro) chipset is sis735

The above motherboard is capable of supporting up to 4 ide drives, I have this board and have

1. Hard drive as Master on IDE1

2. CDRom as Slave on IDE1

3. DVD/CDRW Combi drive as Master on IDE2

If you cannot get more than two drives, have you checked Device Manager for conflicts, or tried updating the sis Hard drive controller.

have you set the jumpers on your drives correctly, if you still have problems, try removing the jumper from the drives (one by one) and see if this helps, or try using the CS(cable select) for all drives.

you say you may have damaged the board, was that the old screwdriver slipped scenario (stupid way to have to fit a Heatsink & Fan), scared me to death doing that. If your screwdriver slipped then you could have damaged the board. doubt it though because you say you can get both drives on as Master or Slave (i think its a jumper problem this one).

let us know

good luck

  keith-236785 07:07 20 Jul 2003

Possible solution is to flash the bios, But only as a last resort (doing it wrong can kill your board), try removing the hard drive controller in device manager, restart your computer and let it re-install the controller.

if you are going to flash the bios be very carefull that you get the right file from ECS Website, there are lots to choose from.

be certain about which revision your board is (1.0 or 3.0), it should be stamped on the board (by the pci slots if i remember correctly)

good luck anyway

  tomhealy 18:16 20 Jul 2003

Thanks for the ideas everyone. I will try them out as soon as i get the chance and let you know how it went.

  ellas 18:26 20 Jul 2003

ah I see what you mean,your new mobo should have come with a 80 conductor cable heres some info click here

  tomhealy 20:47 22 Jul 2003

Well it all appears to be working fine at the moment, all drive recognised and, apart from the dvd which had a problem before, working fine.

Tried to change the HD's to cable select but it turned out that they were already set to that. I changed them to masters and they worked!

If it stays working for the next week i'll consider it resolved.

Now, does anyone no somewhere doing good deals on decent dvd-rom drives? :o)

  keith-236785 07:54 24 Jul 2003

click here,
Liteon 16x48 IDE Internal DVD Drive - OEM

£23.49 inc VAT

+ delivery of course.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?