Ide cdrom will not work on new m/board

  So Afraid 17:31 08 Jun 2011

The sata cdrom and sata hd are fine but the ide cdrom will show in the bios and it will open and close,but it does not appear in windows device manager or anywhere in windows.Tried it again in the old mobo and its fine.

This is the bios setup.

ATA/IDE configuration

Sata11_1 cdrom Primary ide master
Sata11__2 hard disk secondary ide master
Ide1 master cdrom third ide master.

I have also tried

Ide1 slave cdrom with the same result.

  woodchip 18:39 08 Jun 2011

Could it be you are using a 40 wire IDE cable and not a 80 wire

  Fruit Bat /\0/\ 19:29 08 Jun 2011

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41 Try this if the optical drives are not appearing in My Computer or Device Manager. (This is sometimes caused by the removal of Roxio or other writing software.)

CD-DVD-Fix Download and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect. This utility is only intended for Windows® XP, but also appears to work for Vista and Windows 7. You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Similar fixes MSfix works for vista or XP CD gone

or manual fix Run regedit and navigate to registry key HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}. Highlight it and in the right pane, find the Upperfilters and Lowerfilters values. Highlight each one in turn, right click and delete them. Close regedit and restart the computer. If in doubt make a restore point before making changes.

  So Afraid 20:03 08 Jun 2011


Not sure which i have will have to check.

Fruit Bat ^0^

Tried the MSfix xp no good,also there is no Upper or Lowerfilter value in the registry for that key. In event viewer this is what error is there

The \device\ide\ideport0,did not respond within the timeout period.

Event id 9

  Fruit Bat /\0/\ 20:54 08 Jun 2011

see here Bad or loose cables (data) failing DVD drive

  So Afraid 21:50 08 Jun 2011

Tried another good working ide cdrom drive and same result,maybe looking at a failing ide cable?

  Fruit Bat /\0/\ 22:46 08 Jun 2011

Yes try another cable.

  So Afraid 17:13 09 Jun 2011

No spare cable so was thinking 2 ways

this link text or this link text

  gengiscant 17:19 09 Jun 2011

Not sure if this is relevant. ACHI

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)