ICS Set Up But Not Working

  Archie85 19:33 10 Feb 2006

Hi, I have set up a wireless network between my desktop and laptop. My laptop has built in wireless connectivity and I am using a Wireless LAN USB Adapter 802.11g on the desktop. I am connected on a peer-to-peer network and file and printer sharing is enabled and works fine.

I have set up ICS using the Wizard, and have ticked the correct boxes about sharing the connection, but I cannot connect to the Internet on the laptop. I have Telewest and my external modem is connected via LAN in an NIC on my desktop.

I don't want to use a router so can anyone please give me some advice as to what I can try to get the network to work. I have tried disabling the firewall and I have entered the IP address, subnet and default gateway manually on the laptop as it was not working automatically either.

Please help as I have limited knowledge when it comes to networking!

  mgmcc 20:12 10 Feb 2006

I know you have run the wizard, but is ICS set up on the correct connection, which should be the ethernet adapter that connects to your Cable Modem? When you enabled this, it should have configured the Wireless Adapter automatically with the fixed IP address of and Subnet Mask

The laptop should be set to get its IP address automatically which it does by DHCP from the "host" PC. Is it configured this way and does it have an address in the 192.168.0.x range? Windows Internet Connection Sharing tends no to like "client" PCs being given fixed IP addresses.

  Archie85 14:03 11 Feb 2006

Under 'Network Connections' I have a Local Area Connection - NVIDIA nForce NCP Networking Controller, which is the one I have enabled internet sharing on, and then I have a 1934 Connection. I have tried to share the internet on this 1394 connection instead but then all that happens is I lose the Internet on the host computer as well until I change the shared connection back to the Local Area Connection.

  mgmcc 15:13 11 Feb 2006

The "Local Area Connection" is definitely the connection on which you should have enabled "Internet Connection sharing". The "1394 Adapter" is a Firewire connection and not related to your Internet/LAN connection. Your Wireless Network Connection in the PC should have been given the address - has that happened?

If you open a Command Prompt window and run IPCONFIG /ALL you should see details similar to these - click here - but your Local Area Connection will have the Telewest IP address where I have a LAN address from a router. However, your Wireless Network Connection should have the same addresses that I have and, as I've indicated, "IP Routing" should be enabled.

  Archie85 15:28 11 Feb 2006

I have checked the command prompt and IP Routing is enabled and the addresses of the Wireless Network Connection are the same as yours.

Would it make a difference that on the host it is called "Wireless Network Connection 2" and on the client laptop it is just called "Wireless Network Connection"?

Thanks for all your help mgmcc!

  mgmcc 15:57 11 Feb 2006

<<< Would it make a difference that on the host it is called "Wireless Network Connection 2" >>>

No, it shouldn't. For some reason Windows has installed the Wireless Adapter a second time and given it the "2" suffix. You should be able to rename the connection to remove the "2". In any case, you have File/Printer sharing working so the two computers are communicating over the network.

In the TCP/IP settings for the Laptop, try entering Telewest's DNS addresses in the box which says "use the following DNS server addresses". DO NOT CHANGE the IP address settings.

Telewest DNS server addresses are and

  Archie85 18:59 11 Feb 2006

I have entered the DNS settings but no change!

  mgmcc 20:45 11 Feb 2006

Do you have the Zone Alarm firewall in the "host" PC? If so, don't disable it but configure it correctly to allow network and Internet access. Reduce the Internet Zone Security level from High to Medium and ensure the IP addresses of the networked computers are in the "Trusted Zone".

In Internet Explorer's menus, "Tools > Internet Options", make sure that "Never Dial a Connection" is selected. Normally in the LAN settings, all boxes would be unticked but you could try ticking "Automatically detect settings".

Presumably you aren't accessing the internet at all, i.e. an email program also fails to connect to the mail servers?

  Archie85 12:49 12 Feb 2006

Thanks again for the help mgmcc! I had lost all connectivity - the connection said it was connected but I could not share files or printers. I have now changed the settings back so both DNS and IP settings are to be automatically detected and I have installed NetBIOS in the the Network Settings of both computers but still no internet connection!

However, I have done ipconfig/all on the laptop and it says IP Routing is disabled, but it is enabled on the desktop as I have told you. Should IP Routing be enabled on the laptop and if so how do I do it becuase I have already told the laptop to connect through an Internet connection on the host but it has not worked.

  mgmcc 13:34 12 Feb 2006

<<< I have now changed the settings back so both DNS and IP settings are to be automatically detected and I have installed NetBIOS >>>

So is File/Printer sharing working again?

IP Routing should *NOT* be enabled in the laptop, it is enabled in a "host" PC when running Internet Connection Sharing. This is what sends the internet traffic intended for the "client" PC to the correct destination.

  Archie85 13:53 12 Feb 2006

Yes file and printer sharing is working again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?