I think it's the memory.....

  bpj1977 16:01 16 Jan 2006

I recently built myself a new PC (my fourth now) and am having a nightmare with blue screens!

The PC spec is:
Athlon X2 4400
1Gb OCZ Gold Series PC3200 RAM (2x 512Mb)
Western Digital 250Gb SATA2 Hard Disk
XFX GeForce 7800GT Graphics
Sapphire Pure Innovation Motherboard
Hiper Type R 580W PSU
Belkin Wireless PCI Card
Audiotrak Prodigy 192 Soundcard

Running Windows XP Pro SP2.

I have installed all the latest drivers for all components and latest BIOS for the motherboard.

The blue screens tend to appear when I am playing games. They also seem to be very random, I can be playing for an hour and then one will appear or it could be after 5 minutes and it never seems to be at a time that anything specific is happening (i.e. level loading).

The errors I have received so far (on several occaisions) are:
BAD_POOL_CALLER (0x000000C2)

I have run memtest86 (version 3.82) for about 4.5 hours which didn't turn up any errors but searching Google for the errors seems to point towards a physical memory problem.

If anyone can shed any light on this I would really appreciate it, I've been tearing my hair out for a few days now!

  Gongoozler 16:22 16 Jan 2006

As your memory is in 2 sticks of 512M, try using only 1 stick. First try one stick then try the other and see if the problem always occurs with the same stick.

  madPentium 19:40 16 Jan 2006

try a good memory tester. It will be more accurate than trial and error, as both sticks may have a dodgy address.
Anyone here know of a good software memory tester?

  Gringo2005 19:50 16 Jan 2006

May be totally unrelated but had the same problem on my last build!
Was displaying the bad pool caller problem frequently with XP Pro, SP2

Turned out to be some sort of virus software which got through Norton 2003 and stuffed my machine!
Quick re-build and problem solved but I would run some malicious software removal tools first to see if that stops it

Although, as i said, could be totally unrelated

  bpj1977 21:01 16 Jan 2006

Thanks for your responses but it seems the problem is now solved.

The problem appears to be specific to this motherboard, in that it is unable to set the voltage and timings for memory automatically!

I have (since posting my question) gone into the BIOS and set the voltage manually to 2.8v (the recommended) and the PC now seems (touch wood) to be working fine - it stood up to just over an hour of Far Cry with no complaints.

CPU-Z now shows correct information too so I am hoping this is now resolved.

Thanks for taking the time to read and reply, hopefully someone else will find this useful!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

Best Keyboards for Designers & Artists

What to ask Siri on the HomePod

Meilleurs VPN (2018)