I can't play C&C Generals, an error window appears

  Dijpo 10:39 14 Oct 2004


I have been having the same problem with my computer for a while. Whenever I attempt to play "Warcraft 3" or "C&C Generals" an error window appears although this does not happen with "Doom 3" which runs perfectly. The message that appears says: "Please ensure you have Directx 8.1 or newer installed, also check that your drivers are current & up to date" and sometimes it also says: "Make sure your graphics card meets the minimum requirements". OK, I had this problem when I was running my "Gainward 64mb Geforce 4 mx440" and rather than updating the drivers I bought the bad boy "Radeon 9800 256mb" as I thought that as it is a recent graphics card there would be no need for updating the drivers (for a while at least). Also I have always had Directx 8.1 or newer installed on my computer (I recently downloaded directx 9 I it didn't change a thing), and the funniest thing is when I bought "Warcraft 3" nearly a year ago it worked fine for the first 6 months (with my old graphics card). When it was all running fine and I was enjoying "Warcraft 3" I thought I'd buy "C&C generals", however this game worked fine for a few days and then started the hole error message problem I am having now. I have tried several times un-installing & re-installing the games aswell as "Directx" but this has not changed a thing. What I really don't understand is "Warcraft 3" was running perfectly for so long and even when I started to play "C&C generals" that worked fine to (all be it only for a couple of day's).
I really am stuck and after spending over £200 on a new graphics card I really would like to get my favourite games working again. PLEASE HELP

  Diodorus Siculus 10:41 14 Oct 2004

HAve you tried the directX diagnostics:




  Micro-Man 13:14 14 Oct 2004

My sons Generals, Tiberian Sun etc were playing up a while back and reinstalling made no difference. I ended up deleting all reference to the programs in the registry under Westwood or EA software as well as all of the folders for the programs in the Programs Files folder they are installed (bacu up any saved games as necessary). Also delete any temp files you may find before re-installing.

Hope this works for you. I use XP pro by the way.

  stuntmaster 13:21 14 Oct 2004

what it is DX9.0b on some games fail, do you have halo? if so then its the DX9.0b on there that causes it, it does a "Patch" install, sorta hidden.
i had installed that version of DX9.0b and guess wat? none of my games worked except....halo.

my suggestions are this, try and Re-install DX9.0b from a game like NFS underground or similar, jus dont use the halo one. and it will work again, if that fails...... then its a reinstall. unfortunately i had to do that.

workes like a dream if you get the DX9.0b with the installer not the halo one.

  Jackcoms 14:12 14 Oct 2004

Or download the latest version DX9.0c

  Dijpo 15:31 14 Oct 2004

I downloaded the latest directx 9.0C and the problem still ocurred.

Tried to re-install all driver, sounds, video, motherboard etc?

What specification is the machine?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review

Razer's Core X GPU enclosure hands on review: It's cheaper, bigger, and even works with Macs

MacBook Pro keyboard issues and other problems

E3 2018 : dates, conférences de presse, billets et plus