I can't install Linux either way? Please help!!

  Habeeb Okhai 00:04 29 Apr 2017

I've been trying for hours on end for the last 2 days, I have an asus G20AJ but I upgraded it with a 500gb Samsung ssd and a GTX 1060, I can't install Ubuntu!

I have my USB and everything, disabled fast boot on windows and bios and disabled secure boot. All I want is Linux dual booted with windows. I have tried Ubuntu 16.04.5m 17.04, Linux Mint 18 Sarah, GameDrift Linux, Linux Mint 18.1, Elementary os. Attempted each one at least 4 times. All were installed using my 64gb USB, I made partitions etc... did everything FAT32 using rufus, followed YT tutorials, I even did the hold shift while pressing restart and boot from USB, still no luck.

I have 2 monitors, one is plugged into integrated graphics and one is a DVI-D to plug in my gtx 1060. Either I get a freeze, a crash or for Linux mint 18 it asked me for a password or something which I couldn't get. Ubuntu ALWAYS just gives me a black screen once I press Ubuntu, I can't do nomodeset it's just a grub menu which is all black. With Elementary and linux mint 18.1 it just freezes on the logo at a random time.

I did all I could with the settings, if someone could help it would mean so much. So basically with everything but Ubuntu, I have the same menu every time. I always have two options for USB disks and always do both, but either way I have the menu. I press install, (I have tried try OS as well) and then it switches monitor and starts installing which I Getty. The main graphics card (NVIDIA) isn't installed yet so it switches to the monitor with integrated motherboard graphics.

I have UEFI on my pc settings etc... I am starting to think it's because my USB although 64gb can only handle 64 kilobytes 'Cluster Size' and by default which I usually leave it as it's 32, does that matter? Once again my pc is an Asus G20AJ.

I have tried so many things, what is the issue? I have waited ages and ages, there must be a way to fix this. Currently running windows 10 no problem, playing games etc... anyone ever had this error? Is there a way to fix it?

  beeuuem~2 00:40 29 Apr 2017

If you look at click here you may find some help. You certainly aren't the only one with similar problems.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Note 10 Now On Sale: Price, Specification & Features

Best free Photoshop brushes 2019

Apple TV streaming service: what, where, when and how much

Les meilleurs écouteurs et casques audio Lightning (2019)