HP Printer problem

  Rocket Rod 10:04 27 Nov 2003

OS Win98se
This one has me a bit stumped.
Yesterday I had a perfectly good HPdeskjet 656c,I changed a black cartridge, printed a document ok, then today it turned into an Apollo P2500/2600.
The 656 software will not recognize the printer(tryed uninstall/re-install routine). On re-boot the OS finds a new device(Apollo P2500/2600) and asks for the driver. Un-plugged USB diagnostic test printout says the model is now Apollo P2500/2600.
Any ideas before I try to install the requested driver?(already downloaded from HP)

  Lozzy 10:11 27 Nov 2003

I would suggest that you delete the printer off your system then re boot and windows upon re boot will find the printer and re install. Make sure your printer is switched on upon reboot and also have the original HP CD Driver disk and insert it when asked by windows.

Just one thought, the new cartridge you installed it was definitely for the HP 656c.

  Rocket Rod 10:36 27 Nov 2003

Thanks Lozzy

Already tried that. The cartridge was supplied by a local computer shop it's a 'compatible'.

The problem is that the printer thinks it is an Apollo(also a HP product)as per the un-plugged self test. It's as if the printer firmware has been changed. On re-boot the comp 'finds' an Apollo printer not an HP Deskjet 656c.

  MichelleC 11:04 27 Nov 2003

When uninstalling (to reinstall) a printer you need to delete every single file (even in registry via hotkeys). Also your os may need sorting out with sfc.

  Rocket Rod 11:25 27 Nov 2003

I've just tried the printer on a different comp running win98se and it still comes up as an Apollo NOT the HP Deskjet 656c that it is supposed to be.

Any other ideas out there?

  MichelleC 11:30 27 Nov 2003

With printer disconnected from pc but switched on, pull out power cable (not switching off) and this may reset to factory settings.

  Rocket Rod 11:49 27 Nov 2003


No luck with that. I did talk to HP tech support today but they didn't have any ideas either. If I can't resolve this in the next hour or so I'll try setting up the Apollo drivers that I've downloaded from HP.

In the mean time any and all possible solutions are most welcome.


  Wak 14:06 27 Nov 2003

Hi Rod, I've just checked with click here who list the black cartridge for the HP.656C as No.6614
Stratitec do not list the Apollo printers which use the HP cartridges and drivers so I checked on the Apollo web site and they say that the cartridge for the Apollo P2500/2600 is the same as for the Deskjet +400.
Reverting back to the Stratitec web site, they list the cartridge for the HP.+400 as No.51626 which is I think a different animal from the No.6614 so I would suggest that you check that you have definitely got the correct cartridge for your printer as there could be a discrepancy somewhere.
Hope this helps.

  Rocket Rod 15:00 27 Nov 2003

My thanks to all,

I finally received a return e-mail from HP to the effect that the firmware has somehow changed, but the printers are the same. I have installed the Apollo drivers and software, and now have a fully functioning printer again(networked).

While I will call this problem resolved, I am still curious as to how the firmware of the printer got changed.

Again my thanks :-)


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?