How to replace system file in w2k?

  [DELETED] 12:14 13 Aug 2003

I've got an error message re system root and M$ solution is to 'replace Tcpip.sys from os' or 'remove and reinstall TCP/IP...

as w2k hasn't got sfc which is the best way to replace, or how do you remove and reinstall TCP/IP?


  [DELETED] 12:29 13 Aug 2003

Follow carefully

click here

  [DELETED] 12:32 13 Aug 2003

w2k has sfc.

Start, Run, type cmd and press enter.

In the command window, at the C:> prompt, type:

sfc /scannow

and press enter.

Get your w2k CD ready.

Note that ideally you should have sp4 installed first. Then sfc wouldn't replace system files updated by Windows Update with the old CD versions of the files.

  beeuuem 12:34 13 Aug 2003

These may help
click here

click here

  [DELETED] 15:15 13 Aug 2003

Thanks for replies, guys.

I'd like to replace file as this seems safest.

I did cmd, typed sfc/scannow and inserted os cd, it completed scan then os disc install panel came up with options

Install w2k

Install Add-on components

Browse this cd

but there's no option to manually reinstall a file. I tried renaming Tcpip.sys adding 'old' rebooted, thinking this would force os into replacing but no.

  [DELETED] 15:27 13 Aug 2003

ensure that you put in the space:

sfc /scannow


  [DELETED] 15:28 13 Aug 2003

you can shut down the windows install screen or alternatively, when sfc asks for you to insert the CDROM hold the shift key when you put in the disc for a few seconds and this will cancel the autorun on the CD. Then click on retry on sfc.


  beeuuem 15:55 13 Aug 2003

Can you copy the file from the CD?
click here;en-us;816/7/43

  beeuuem 15:57 13 Aug 2003

Or even click here

  [DELETED] 18:31 13 Aug 2003

How did your original error message come about that you were prompted to 'replace Tcpip.sys from os' or 'remove and reinstall TCP/IP...

Can you explain?

  [DELETED] 09:23 14 Aug 2003

Since upping from 98se to w2k I've had probs capturing and printing to dv camcord. I've tried every which way to resolve. Now this error pops up.

sfc is not picking up any corrupt files, so I can't manually change any 1 file (not like the 98 sfc).

When I changed Tcpip.sys by adding 'old' when rebooting (or sfc) it forced os to reinstall the file. But error message still comes.

I'm going to swap firewire card into another pc and try and sort another way.

Another error message pops up saying 'there isn't enough data rate necessary to perform action'. But I've set the 'paging' to 2 x ram at 1000 min and 1800 max, so should be enough.
Thanks anyway all.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best computer security tips

Meet Superfiction, the little design studio with a load of character

Best Mac buying guide 2018

Comment résoudre les problèmes de connexion internet d’un iPhone ?