How to remove 2nd copy of XP Pro

  [DELETED] 19:37 08 Oct 2003

I have accidentally installed a second copy of XP Pro onto my HDD.......I meant to install it onto a second spare disc.

When i reboot my pc and realised when i have just done i pulled the plug...ouch...and now every time i reboot my PC, i get to choose which os do i want to use(of course they both have the same name). The default is the faulty os(as i pulled the plug remember?) and i get an error message saying there was some hardware problem.

The other option works fine as it is the origianl os.

Question is how can i remove this default faulty that i do not have to choose which os to use each time i reboot ..just like as it always used to be.

Appreciate for any help.

  [DELETED] 20:07 08 Oct 2003

Think I know the correct answer, and it will involve inserting the CD and formating the Copy you wish to remove. But I will let someone with more experience help out on this first, I would hate to instruct you to remove the wrong install.

This will at least bring you back to the top of the page for others to see. j.

  [DELETED] 20:19 08 Oct 2003

1. Remove the second copy from C:\boot.ini. Type at the Run prompt:
c:\boot.ini. This will open boot.ini in Notepad. Delete the wrong entry
under [operating systems]. Save and Exit Notepad.

2. Remove the second "boot folder" to recover its disk space. If you have
only a single volume (Drive C:), the first one is, by default, C:\Windows.
The second one might be D:\Windows, or C:\Windows2, or some other such name.
WinXP won't let you delete the one it is using, but if you are booted into
the copy that you want to keep, it will remove the folder (with all its
files and subfolders) for the other copy of WinXP.

  [DELETED] 20:26 08 Oct 2003

i dont think you will be able to just uninstall the bad win XP, to change the default boot option.

1. right click My Computer

2.choose properties

3. click the advanced tab

4. in the Startup And recovery section click the Settings button

5. the default windows will be highlighted in blue, click the down arrow at the end and choose the other windows XP as default.

6. click OK, then click OK again.

7. shutdown and restart, see if your default is now the good win XP.

if you want to change the time of the countdown you can at the same time as you are choosing the default boot option,follow steps 1 to 4, the time at the end of "Time to display list of operating systems" has a number, click the number then type 0 or 1, click OK, then click OK again.

the next time you boot up, you wont have to do anything as it will choose the default for you. Make sure that the default is the actual good version and you should be ok.

you can also edit the boot.ini file to remove the boot option completely but im not sure exactly what to delete.

follow the steps above should provide a work around, although not perfect it will work.

  [DELETED] 21:05 08 Oct 2003

paperman27, once you have removed the second copy from the boot.ini file you won't have to change the boot option..


  [DELETED] 22:16 08 Oct 2003

thanks for that, i wasnt sure enough to tell freefx what to remove, and i didnt want to have them deleting something wrong.

as i said it wasnt perfect but it does work.

still in the time it took me to write that answer you had already posted back but hey choices are

hope freefx got his/her answer anyway.



  [DELETED] 09:47 09 Oct 2003

I had this prob on my w2k setup. In case you can't find boot.ini:

You need to uncheck Hide Protected Operating system files;

I made a backup before editing the file. In addition make sure you remove the read only attribute from the file; you can change it back to read only after you finish editing.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple