witchblade 19:20 01 Jan 2004

I have a pc here a friend of mine asked me to upgrade its a gateway 2000 and the hard drive i am replacing was a 2gig and i managed to get a 10gig hard drive to replace it with. The drive has been pre formated. I put in the windows 98 boot floppy and waited for the prompt and was thinking it would be ok not to partition the hard drive but just put on the op system but it wont do that what has come up is

Windows has detected that drive c does not contain a valid FAT or FAT32 partition there are several possible causes.

1, the drive may need to be partitioned. to create a partition run fdisk from dos command prompt.
2, You may be using 3rd party partitioning software (not using any software)

3,Some viruses also cause your drive C not to register

The diagnostic tools were successfully loaded to drive c.

I think no 1 is what i need to do and i have not partitioned a hard drive before if you can suggest some sites that will give me a tutorial on how to partition i can have a go with that unless you think there is some other reason i cant get the op system to install i would love to hear from you.


  MAJ 19:28 01 Jan 2004

You'll need to fdisk the drive first and use all the space (10gig) to create a primary DOS partition. You can create more partitions if you wish with fdisk, but a 10gig partition will be okay to start with. Try this page click here for instructions, it's fairly straightforward. Scroll down a little to the "How To Partition, Format and Install" section.

  OneSirKnight 19:30 01 Jan 2004
  LastChip 19:30 01 Jan 2004

It sounds like the drive is not formatted, or is formatted with a file system that Win98 cannot recognise (NTFS for example).

At the DOS prompt you get from the floppy, if you type

format C: [enter]

What result do you get?

  witchblade 19:53 01 Jan 2004

LastChip tried format c Result was parameter fromat not correct - c

Also tried fdisk and it says no fixed disks present. do u think there is a problem with the hard drive.

  witchblade 19:57 01 Jan 2004

MAJ Thanks for the link but am unable to do it as it wont fdisk as it says no fixed disks present.

  MAJ 20:03 01 Jan 2004

That doesn't sound promising for the hard drive, witchblade. Do you have another PC that you could install the drive on to as a slave, to see if it is detected? Or go into the BIOS of that PC and make sure that the BIOS is set to Auto-detect the drive on the IDE channel that it's on?

  witchblade 20:08 01 Jan 2004

MAJ Was thinking the same thing myself have another 2 pc,s in my house will install it on my pc and post back with the result.

  LastChip 20:10 01 Jan 2004

The command is;

format C:

That is; format - space - C and colon, then press enter.

This command is initiated from your floppy boot disc, therefore, you should be at an A:> prompt when typing the command. The whole thing will look similar to this;

a:\>format c:

Your A: prompt may look slightly diffrent. Is that all correct?

Likewise, if you wanted to initiate fdisk, it is also from an A: prompt, perhaps similar to this;


  witchblade 21:22 01 Jan 2004

here is an update i managed to get the drive detected in my pc. and no it was not formated as was told to me when i got it from ebay here is a link to the auction so you can see for yourself

click here i have managed to format and have windows 98se installed on the hard drive now. I installed it back into the gateway pc and its not detecting the drive so i tried to detect it but no joy dont know what to do next i only have a little knowledge on p.c,s if you have any other suggestions i would really appreciate it.


  witchblade 21:30 01 Jan 2004

LastChip Just to confirm A:\>format c: and for fdisk A:\>fdisk thats what i typed in after the a prompt.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)