How do I get my lap top to accept the network key?

  ardeebee 11:34 09 Jun 2013
Locked

I have 2 old laptops both running on Windows XP, which I am trying to connect via WIFI to a Belkin router. I have set up a network connection on each laptop. One works fine but the other will not accept the network key which I know to be correct. I can see that the "properties" of the connections are different but can't see how to change them. The non-working connection is headed "Wireless Network Key(WEP)" and has 2 fields which cannot be changed. These are:- Data encryption(WEP enabled) and Network Authentication(Shared mode) The working connection is simply headed "Wireless network Key" and its 2 fields are as follows:- Network Authentication (this is set as WPA-PSK) and Data encryption (this is set as AES)

Both laptops did connect before I did a recent "Quick restore". Any suggestions, please?

  difarn 07:27 10 Jun 2013

Have you tried clearing the network connection on the pc that is not working then connecting it by ethernet to the router and then trying to connect?

  ardeebee 10:14 10 Jun 2013

I'm not sure what you mean by "clearing the network connection" on the non-working laptop. However, I have tried connecting via an ethernet cable and this works fine. But when I then try to connect by WIFI the problem is still there. It will not accept my (correct) password and gives the following message "The network password needs to be 40 bits or 104 bits depending on your network configuration.This can be entered as 5 or 13 ascii characters or 10 or 26 hexadecimal characters" I think this is because the Network connection is configured as WEP (whatever this is) and cannot be changed whereas on the working laptop the Network authentication is set as WPA-PSK and the Data encryption is set as AES with no mention of WEP at all! Any further suggestions, please?

  difarn 21:40 10 Jun 2013

I suggested clearing any reference to a network connection then connecting by ethernet as this often does the trick when you try to connect again wirelessly.

Try

Control Panel - Network connections Right click on the wirless network connection properties dialogue window Click on wireless network tab select wireless connection you want to connect to from the preferred list Click Properties button Click on the Authentication tab Uncheck the box Enable IEE 802.1x authentication for this network Click on connection tab inside Properties dialogue window Check the box "connect when this network in range" Click ok inside the wireless connections and wireless properties windows Try connecting to the network

If this doesn't work try this Fix-it from Microsoft

  onthelimit1 09:40 11 Jun 2013

If it is an OLD laptop, then I'd suggest the wireless card is not compatible with the later router security. You could try changing the router to WEP and see if it works then. The alternative is to buy a mini wireless dongle for under a tenner which will work with WPA - webpage here.

  onthelimit1 09:41 11 Jun 2013

Whoops, sorry - misread your post. I see you're already on WEP.

  onthelimit1 09:43 11 Jun 2013

I must be tired having been up all night with a new (8 week old) lab puppy. I think your problem may be as per my original post if the connection is try to use WPA.

  ardeebee 18:42 11 Jun 2013

difarn - I do not know how to remove (clear) the reference to the existing network connection. I have tried following your latest post until I get to "Click on connection tab inside Properties dialogue window Check the box "connect when this network in range" Click ok inside the wireless connections and wireless properties windows Try connecting to the network" but I'm not sure which Properties dialogue window you are referring to.

onthelimit1 - My problem is that the non-working laptop seems to think that the router is WEP but I've checked and it is set as WPA/WPA2 with Authentication set as PSK. The working laptop's Network Authentication is set to WPA-PSK with Data Encryption set to AES. The non-working laptop did work before I did a Restore although I've no idea what the setting were before (it just worked straight away so I had no need to look).

Incidentally, I've no idea what all these things mean. I'm just reading the screen!! Help, please!!

  ardeebee 18:48 11 Jun 2013

jaywoo - Thanks for that. Your reply came through as I was typing my previous responses. I'll check but I suspect that I probably haven't got SP2 installed. I'll do that now. I did mean Factory Restore, by the way. Thanks.

  difarn 21:18 11 Jun 2013

The properties dalogue window is the one you opened when you right-clicked on the wireless network connection. If you have got as far as unchecking the IEE 802.1x then you should see a Connection tab - this is where you shold see the "connect when this network in range" option.

If this does not work you could try the link to the microsoft fix given in my earlier post.

  ardeebee 21:39 11 Jun 2013

No, couldn't see the "connect when this network in range" option at all. Also tried the Microsoft fix without success. However, the problem is now fixed thanks to Jaywoo's suggestion regarding Service Pack 2.Evidently my Factory Restore goes back to pre-SP2 days when WEP is the only Network type supported. As soon as SP2 was installed the Network connection recognised my correct (non-WEP style) password and connected immediately. Thanks to all who replied with suggestions but especially to Jaywoo, who cracked the problem!!

I've got 1 or 2 other issues with this same laptop which I will start new threads on, once I've got sorted. Thanks, again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Camera Phones 2019

Adobe reveals Recolor for Illustrator - change an illustration instantly with real-world tones

Apple recalls wall plugs over safety fears, find out if you are affected

Rappel de sécurité Apple : adaptateurs avec prise murale