home network and file sharing

  roi 01:01 22 Dec 2005

I have set up a small home wireless network (desktop and laptop). On the desktop under mshome I see only the laptop, and I can access its files. On the laptop under mshome, I can see laptop and desktop. However, I cannot access the desktop, being told it is not accessible and that I might not have permission. I am advised to contact the network administrator (me!). How can I overcome this problem? I have allowed file sharing on both desktop and laptop (both of which run Windows XP Home).

  CLONNEN 08:17 22 Dec 2005

Have you set at least 1 folder or drive on the desktop machine to Shared?

If there aren't any shared folders you will not be able to access anything because there is nothing to access.

Has your desktop machine got an Administrator Password on it? - I had to set my Admin Password to blank in order to get file sharing working correctly on our home network.

  roi 10:03 22 Dec 2005

Thanks Clonnen. I have set shared folders, and the Administrator password is blank.

One possibility may be that somewhere down the line I have disabled remote access or a similar permission, and it is now a matter of ploughing through all obvious (and not so obvious, this is Windows after all!) places to try to locate and re-enable it.

  ade.h 21:43 22 Dec 2005

Remote Access bears no relation to File Sharing on a network, so that can be ruled out.

It is not enough just to enable File & Printer Sharing; you have to create some locations in My Network Places. Otherwise, all that you will see is Shared Documents, I think.

  Daveboy 22:43 22 Dec 2005

same here !

I had a similar problem recently, I had a response from "Lastchip" that cured it for me:

OK, try this but be careful.
I, like our Forum Editor, am reluctant to post Registry Hacks, because they can go wrong - Big Time, but sometimes, it is the only way to overcome a problem. So please read this with care and follow the instructions precisely.


First: Go to Start; Run; and type; regedit [OK]

Navigate to;


and look for a DWORD restrictanonymous and see what the value is. If it is anything but 0 (zero), close regedit to follow the next part of this post. If it IS SET to 0, this post no longer applies and it isn't the root cause of your problem.

Next, go to System Restore and make a backup of your system, in case things go wrong.

Now, reopen regedit and as a further backup, go to Registry (top left) Export Registry and save a copy of your registry to the root drive (C:). This is a further safety net should the need arise. I don't wish to frighten you and with this hack, things shouldn't be a problem, but you can't be too cautious when dealing with the registry.

Finally, navigate back to restrictanonymous (as above) RIGHT CLICK the DWORD, select MODIFY and change the decimal value to 0 (zero).

A further word of warning, there is a DWORD restictanonymoussam just below the one you want - DO NOT change this.

Now close regedit and reboot your computer with your fingers and toes crossed ;-) and all should be well.

  roi 01:24 23 Dec 2005

Thanks Daveboy, but it was set to 0.

Now I don't even see the desktop on the network, only the laptop!

  mgmcc 07:51 23 Dec 2005

Do you have any firewall software correctly configured to allow access to the networked computers, normally done by adding their IP addresses to the "trusted" area?

  roi 11:38 23 Dec 2005

Thanks mgmcc. I checked my permissions. I also checked the Windows setup, and discovered that not all options had been installed: for example parts of 'Networking Services' were absent - on both machines. I have now done belt and braces, and installed all the absent components - and Eureka, I have file sharing on my home network!

Thank you all for your help and suggetsions.

Have a Happy Christmas.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)