hh3 and external hhd

  lossie 12:21 31 Jan 2012

I have attached an external hhd to my BT Home Hub 3 using the usb port. All computers on the network can access the drive to read and delete files but it will not allow me to add files. Is there something obvious I am missing? I am using w7pro 32bit

  difarn 14:29 31 Jan 2012

There are comments on other forum about external hard drives needing to have their own power supply to be able to write to it (apparently there is enough power to read and delete) - there probably isn't enough power just through the usb device. Is your HD mains powered?

The home hub 3 says that the usb port is enabled for use so that should not be a problem.

If the power isn't the problem have you assigned all of the relevant permissions?

  lossie 17:59 31 Jan 2012

hdd is powered. I have tried changing permissions but it doesn't let. I have tried mapping the drive on my pc that just locks me out.

  difarn 19:19 31 Jan 2012

It could have something to do with the format of the hard drive - some routers will read files formatted in NTFS but needs to be formatted to FAT 32 in order to have files written to it.

Have you been successful when the hard drive has been directly connected to your PC.

  lossie 09:30 01 Feb 2012

hdd is formatted to FAT32 and when connected direct to pc I can add files but it is a bit of a pain to have to keep disconnecting it from the hub and then reconnecting it

  difarn 10:43 01 Feb 2012

You say you have looked at permissions - did you in fact look at those of your external hard drive?

Open Removable Storage. In the console tree, right-click the specific item you want to change user permissions for, and then click Properties.

In the Properties dialog box, click the Security tab. Click the name of the user or group whose permissions you want to change, and then do one of the following: To change specific permissions, select or clear the Allow and Deny check boxes for each of the three levels of permissions: Use, Modify, and Control, as applicable

You may like to read through this article to see if there is anything obvious to you.

  lossie 11:13 01 Feb 2012

Yes I have tried all that it will not save any changes to permissions. Mapping it on the pc locks me out. Reading the other thread you mentioned it appears I am not alone I have tried all the routes suggested there already and have the same problem as mentioned there. It seems strange I can delete files but not add them.

It may be a hh3 issue and not a windows issue. Looks like I will need to keep using the long route


  difarn 13:07 01 Feb 2012

When you were setting up the hard drive on your home hub did you have to set up a BT workgroup - this BT Home Hub help intimates that this is what has to be done.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)