[Help]Install Windows by Internal EFI Shell

  Hany 09:50 26 Jan 2017
Locked

Ok. So I have many questions to ask. But let me give you a backstory/How I got here.

Device

Intel Tablet. NO KEYBOARD. It Ran Windows 8.1 PRO. 32 GB Storage and 2 GB Ram. It was a 32 bit touch computer thing. It had 1xUSB3.0 Port. 1xHeadphone jack, 1xCharger Port, 1xMicroHDMI Port, 1xSDCardSlot.

Backstory

So my Windows Boot Manager no longer works. It somehow got erased after it powered off during an update.

So I thought Hmm. I'll just reinstall it via a USB Boot. The problem is. I don't have a Keyboard to change the boot Order in the BIOS. So I was stuck over there.

Under the Exit category of the BIOS, I did something like Load Default Boot settings which changed it up a bit.

The order was:

eMMC Disk

USB HDD

then the rest.... Windows boot manager was at the last (FYI)

So I did save changes and exit. After that, the EFI SHELL started every time I powered it on. I searched tutorials on how to install Windows through it, but it didn't work.

This is what I tried:

fs0:

cd EFI\

cd BOOT\

bootia32.efi

BUT, every time I did that, it said "Bootia32.efi is not recognized as an internal command or batch file......." (Note that the USB was plugged in at all times)

I got stuck there now. So I noticed that IF I wrote the "exit" command on Shell, it would bring a pop up with a list of things to boot from.

I saw USB HDD: Generic USB Flash (my USB) and double tapped it (it's a touch screen). But nothing happened and it would show the same menu again.

Few Notes

I was able to type things in the Shell cause a virtual keyboard appeared over there.

I installed a 32 bit version of Win8.1 from GetIntoPC.com as I didn't have my license number/ product key.

I installed it through Rufus to an 8 GB USB.

I also followed a tutorial where they told me to go into the ISO file, go to sources/install.wim, open that using 7-ZIP, go to EFI/Boot and find a file called "bootmgrw.efi" <- something like that. Copy that file, go to the ISO/EFI/BOOT/ and replace "bootia32.efi" with that file I copied and rename it to "bootx64.efi". (I know x64 is for 64 bit. I did that as a test. I haven't tried renaming it to bootia32.efi yet, so forgive me)

Questions

What am I doing wrong in the Shell part?

Why doesn't opening USB Generic from the menu work?

Is it possible to install Windows in Shell in 32 bit computers?

When I open the Menu after using the exit command, and select USB HDD, why doesn't it open? Is it some incompatibility problem? Is it corrupted? Is it just messed up?

If you need Any more details, I can reply to you ASAP. Please help me out. Thank you.

  Fruit Bat /\0/\ 17:27 27 Jan 2017

It possibly ships with a 64-bit EFI implementation. An EFI can boot only 64-bit OSes in EFI mode.

So to boot a 32-bit version of Windows, you must boot it in BIOS mode. Microsoft has decided that it won't support booting in BIOS mode from GPT disks

This requires converting the partition table ( the entire partition table; not just a single partition) from GUID Partition Table (GPT) to Master Boot Record (MBR).

fs0:> \EFI\BOOT\BOOTX32.EFI

bootia32 I believe is only for the Itanium-based computers.

  Hany 17:38 27 Jan 2017

So um. What do I do? Can you guide me or? Please?

  Fruit Bat /\0/\ 20:55 27 Jan 2017

don't use change directory (cd)

just type

Shell> Fs0:

fs0:> \EFI\BOOT\BOOTX32.EFI

if your drive is MBR it may work if not the you're going to have to use a bootable partition tool to change GPT disk to MBR.

However what chip is in the tablet can it run a 64bit system?

  Hany 10:33 28 Jan 2017

The thing is, when I do LS after going into BOOT folder they only show "Bootia32.efi". Do I write BOOTX32.EFI? Or BOOTIA32.efi?

I'm not sure whether it can run 64 bit system

  Fruit Bat /\0/\ 10:52 28 Jan 2017

Bootia32.ef

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

iPad 9.7in (2018) review

Test : les écouteurs Bluetooth Honor xSport AM61