Help with Toshiba A40 laptop please

  Never again 17:54 30 Oct 2008


My friends daughter has a Toshiba satellite A40 Laptop, which was running windows XP.

On starting she now gets the message
"PXE-E61 media test failure - check cable"
"PXE-M0F exiting intel boot agent"
"insert system disk in drive"
"Press any key when ready"

and then the laptop won't boot into windows.

I thought that the hard drive may have come loose, so I took it out and refitted it, but to no avail.

I have also tried to reinstall with the recovery CD's but get the following error message
GDISK (E) no such fixed disk 1"

this is followed by ***ERROR***
error number 11030
message invalid destination drive

I checked some previous threads and downloaded and ran a Toshiba (or it might have been Hitachi)disk checking utility which I burned to a cd and ran on boot up.

This said that there were problems on Toshiba MK4025GA5, which is the hard drive. the details match up with what it actually says on the drive.

The bios can see the drive to boot to as it is listed as the master, with the cd drive as the secondary.

Therefore, is it the case that the drive is broken. If so - can it be repaired or is there another solution.

I have tried googling this message also, and there are conflicting messages regarding this issue, so your help would be much appreciated.

Thanks in advance.

  Never again 09:06 31 Oct 2008

Sorry for bumping it, but I was hoping that someone might see it this morning as it was posted last night after most people had gone home from work.

  crosstrainer 09:10 31 Oct 2008

Almost certainly hard disk failure I'm afraid...The setup cd cannot find the hard drive.

You could check the cables again, but a replacement and full re-install sounds on the cards.

Your local Toshiba dealer should provide you with a quote for the work prior to undertaking any repair.

  Never again 17:22 01 Nov 2008

I thought that might be the case, but is this a common problem?

The laptop is only out of warranty by 6 months.

Its a bit dissapointing - hard drives are supposed to last for years.

It makes little sense nowdays having a dealer repair quote out of warrantly as it racks up quite a bill. New laptops can be bought for as little as £300.

Its economic madness - and such a waste.

Thanks for your advice anyway.

  Fruit Bat /\0/\ 17:37 01 Nov 2008

Its trying to load from a network drive rather than the hard drive.

1. remove and refit the drive , it could just be a bad connection

2. check in the BIOS that your Hard drive is set as the first boot device.

  Fruit Bat /\0/\ 17:43 01 Nov 2008

Note to self :-
Must read thoroughly and comprehend before posting.

If the drive has data on you require maybe you could connect to another machine using a caddy to retrieve that data.

Boot from an XP disk and go into recovery console and run fixmbr and fixboot.

Using Recovery Consul
click here
click here

  Never again 18:24 01 Nov 2008

Thanks Fruit Bat but...

I tried booting from an xp disk but got another error message, which i wrote down but can't find now.

I think it was "page fault in non page area" but the installation would not continue.

I was hoping to install xp from disk and then reinstall with the recovery cd's to keep it legal.

I am told that there is no important data on the drive so that's not a problem.

I have had the drive out 3 times now so a loose connection is probably not the answer.

Thanks anyway

I also checked the boot order and it is set to HDD first.

  Fruit Bat /\0/\ 18:30 01 Nov 2008

Set first boot device as CD drive second as HDD.
save and exit.

then boot with XP CD in drive and run recovery console.

If BIOS can see drive then physically nothing wrong.
If XP cannot see drive then masterboot record is likely to be corrupt hence run fixmbr.

  Never again 20:35 01 Nov 2008

I have run the recovery console which seemed to detect the drive and now have the message to type EXIT to quit and restart and the the path or file specified is not valid, and a C;\prompt.

I'm not sure what to do now?

  Never again 07:40 02 Nov 2008

I managed to run fixmbr and all seemed to be working ok.

I then ran the recovery disks and on first boot windows failed to load.

I then tried the last known good configuration option but that did not work.

I then tried the safe mode with command prompt option, and booted to a c: prompt.

I then run chkdsk and it reported ok but to run with A /P to check the volume. This has run to 27% and reported that the volume appears to contain one or more unrecoverable problems.

Is that it then - a dead drive?

  Fruit Bat /\0/\ 10:32 02 Nov 2008

Yes I'm afraid there is very little else you can do.

try running something like kill disk on the drive and then try a reinstall, but I fear a new drive is the safest option.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?