HELP! Suicidal over SATA

  Newuser1158 19:42 27 Feb 2005

First off - I am not new to building and upgrading my computers - but, this is the first one I have built with a SATA hard drive. When I tried to install Windows XP, during the set up it said it could not find a hard drive. A search on the net revealed that I had to copy drivers from the mobo CD to a floppy, and then press F6 during the XP install (no mention of this in the mobo manual - an Asus K8v SE de luxe)
Did this but the XP set up could not find the drivers on the floppy or gave me an error message.(file txtsetup.oem caused an unexpected error.........)
Back to the net for more help - bought a new floppy drive, installed it in old computer, copied files, transferred floppy drive to new computer, and tried again.
This time the floppy was detected and I loaded WinXP Promise SATA controller.
Cracked it I thought!!!
However after Windows set up loaded more files and arrived at Windows set up - press enter - guess what - it still says it did not find a hard drive.

Any help would be appreciated before I stick the SATA on Ebay and go back to IDE drives.

  SANTOS7 19:49 27 Feb 2005

click here
some good info here it may help....

  Newuser1158 19:59 27 Feb 2005

Thanks, already have had a look at this website, but I have a Maxtor drive - I guess this will only help with Seagate drives

  ICF 20:01 27 Feb 2005
  Phphred 20:08 27 Feb 2005

Just make sure that you are in fact pressing F6 key eapecially if you have a fancy keyboard!

  daxian 20:10 27 Feb 2005

hi newuser1158,
i have the k8ne deluxe and use a sata drive.
on the one i use there are 6 sata ports ,dont know if its the same on yours .
i used the ports nearest the ide and did not need the drivers to set up .
i think it would have been a different story if i used the other ports as they use a different controller .
thing is there are 2 sets of drivers one for the nvidia chipset the other for the promise chipset might be worth checking if yours is the same .

  Chegs ® 21:13 27 Feb 2005

I have 2xSATA 120Gb (Maxtor) I had a major hassle setting up my puter with XP.The "txtsetup.oem" error occurs quite frequently,resolved by waiting until XP requested the floppy disc before inserting it.The second problem (disappearing hdd's) also occurs whenever I switch off the pc for awhile,cured by at switch on enter BIOS cfg screen and waiting a few minutes before exiting and allowing pc to boot up.I thought it might have been a symptom of pending death of hdd's as both SATA's ultimately died within a week of each other.I obtained a pair of replacement SATA's from Maxtor,which have functioned perfectly since(approx 4 mths old when pair died)but still require a few minutes to "gather themselves together" at 1st boot.I got so sick of having to find a workaround with SATA only system,I installed my IDE 15Gb drive to carry XP,and everything else goes on the SATA's(games/downloads,etc)but not before I have burnt the important stuff to DVD-RW.

With the now dead hdd's,I had tried newer hdd firmware,newer SATA driver,flashing the SATA controller,etc.I couldn't find anything online from anyone experiencing similar troubles,although I found a lot of info from the linux folks who were having hassles getting SATA running in linux,but I tried Suse recently and it found my SATA setup and installed its own driver which worked flawlessly.

  NotsoNewuser 23:12 27 Feb 2005

I too have a new K8V SE DL mobo and have put two IDE drives and two IDE SATA drives.
There are two drivers on the mobo disc one for IDE SATA and one for RAID.
You will have to reload XP and make sure you press the F6 at the right time, you don't get much of a chance, that will then take you through it. You use the disc twice.
See page 5.8 of the mobo manual on creating a driver disc.
Dont forget to set your BIOS for IDE SATA as well.

  Newuser1158 12:41 28 Feb 2005

My sincere thabks to those who took the trouble to reply. Apart from the problem with my floppy drive, I didn't realise that there were Promise and Via drivers. I had hooked up my hard drive to the Via controlled socket and was trying to load the Promise drivers. One gripe, however, why in this day and age do we still have to fit a floppy drive just to install a few drivers?

Thanks again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Radeon Adrenalin release date, new features, compatible graphics cards

Indie publisher Canongate’s top 10 book covers of 2017

New iMac Pro release date, UK price & specs rumours

Tablettes Amazon Fire : quel modèle choisir ?