Help re Primary IDE Contoller

  Mr Tibbs 22:33 06 May 2003
Locked

I have put a different hard drive in what was our first computer so I can give it to one of our friends. I formated the disk and put our old Windows ME on it but now when I go to Device Manager there is a yellow exclamation mark next to the Primary IDE controller(dual fifo). When I go to properties the Device Status states 'this device is either not present, not working properly or does not have the drivers instaled'. In drivers it states the driver is from microsoft.
Before I give this computer away I'd like to know how much of a problem this is, will it cause problems when using the computer and what can I do about it. I've tried reinstalling windows but that hasn't helped. Any help would be appreciated, thanks.

  hugh-265156 22:43 06 May 2003

try windows update click here

  AndySD 22:49 06 May 2003

It may be you need to load the motherboard chipset drivers. If you know the make/model of the motherboard post it here and we can look for you. If not try Belarc Advisor click here

  Legolas 23:34 06 May 2003

You could try removing the IDE controller and then when you reboot windows will detect the IDE controller and reinstall.

  Mr Tibbs 14:40 07 May 2003

Thanks. I've tried removing the controllers but when I reboot they are reinstalled as before. The motherboard is a MSI MS6156 ver1.0BX7 with a intel 82443BX/PIIX4E chipset. Does anyone know where I can get the drivers from to give that a go. Cheers.

  Legolas 16:31 07 May 2003

Have a look here one of these might drivers might help
click here

  BRYNIT 16:46 07 May 2003

Go into Bios and check HD settings. If you had two HD on this computer it may be looking for it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HP Envy x2 review: Hands-on

Iconic New York graphic designer Milton Glaser on his uplifting new subway posters

New iMac Pro release date, UK price & specs rumours

Comment suivre le parcours du père Noël ?