Hot Topics

Help needed to Turn on WiFi on Netbook

  schmollies 11:34 24 Jul 2012


I have a Zoostorm netbook but it will not connect to my home router. It does connect at my office, in hotspots and worked fine recently in the USA.

I have another larger Dell laptop & this connects no problem at home.

So it seems that the Wifi on the netbook must be working & the router must be working but why cant they connect with each other?

Using Windows 7, ISP is Talk Talk & the Router is a fairly old Siemens.

Any ideas? Ray

  Clapton is God 12:08 24 Jul 2012

Have you entered the details of your home router (network name and password) into the netbook?

  recap 12:25 24 Jul 2012

Ensure that Wifi is active, it may have been disabled in transport, Fn/F2 should turn the WiFi back on.

  robin_x 12:31 24 Jul 2012

Check that security setting matches on both (WEP, WPA OR WPA2).

WPA2 is the recommended most secure.

  schmollies 12:53 24 Jul 2012

Thanks for the replies so far.

To try & activate the WiFi, I have to press FN/F2 but nothing happens; ie the usual little light flickering light comes on to say it is active. Until I can "open" this I can't enter the router details into the netbook!

No problem with my other laptop. I am baffled!


  Clapton is God 13:40 24 Jul 2012


But you've already told us that the netbook's wi-fi works fine on other networks so it must be active.

  recap 13:58 24 Jul 2012

I don't know the netbook you have schmollies, is there a Networkplaces icon in the Start menu? If there is you could add to a network.

  schmollies 14:00 24 Jul 2012

Hi Mr Clapton,

Sorry if I have confused you and others. I can turn the wifi on by pressing FN/F2 in other hotspots & log on to the internet,so yes the wifi does connect on the netbook.

It is just at home that I cannot turn on the wifi, when I press FN/F2 nothing happens. Until I can turn it on, I can't enter the router details.


  Clapton is God 14:12 24 Jul 2012

So, at the risk of sounding facetious, why don't you go to one of those other hotspots, switch on the wi-fi, leave it switched on and then go home.

The wi-fi should still be active when you get home.

If it isn't, report back here.

On another note, why do you need to turn the wi-fi on and off, anyway?

  onthelimit1 16:39 24 Jul 2012

Unless by 'turn on', you mean 'connect'? If so, you may be entering the wrong security code.

  schmollies 20:19 24 Jul 2012

Hi All,

Problem now solved. Wifi on netbook was not enabled.

Thanks for your help.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Huawei Mate Xs could’ve been the first great big-screen foldable

Doodler Jon Burgerman has a great body (of work!)

Apple Arcade ain't what it used to be

Test : le Yoga C740 de Lenovo