Help, damsel in distress!! Bluray Invalid Pointer

  TinkyTime 13:31 02 May 2009

Hello. I am new to this and hope you can help.

I have a new PC.

Windows XP Pro SP3 (havent downloaded any updates yet)
Creative X-Fi Extreme 7.1 Sound card
i7 920 Processor
3Gb of Corsair XMS2 Ram
ASUS P6T Motherboard
ASUS Radeon 4850 512MB
ASUS DVD Rom Drive
LG Blu Ray writer (which came with Cyberlink High Definition Suite and have downloaded the patch it suggested for Power DVD 7.3 to play Blu Ray).

DVDs play fine but when i put a Blu Ray disc in a little box appears saying "Invalid Pointer Error Code 80004003"

So i disconnected the DVD player, Removed the sound card and enabled the onboard one, Replaced the graphics card for an old 8500GT and lo and behold, blu ray works lovely.

Installed the Creative sound card, disbaled the onboard and blu ray played for 10 mins each time before machine restarted. I had a look in Event Viewer but no errors, just a note implying I had turned it off properly!

Ran Cyberlink Blu ray Advisor and says everything is perfect, but clearly its not..

So removed the sound card and went back to onbard and all fine again.

Replaced the Graphics Card for the Radeon HD4850 512MB and installed all the latest drivers and same Invalid Pointer Erros 80004003.

Ran Blu Ray advisor and it says monitor is not HDCP compliant, Graphics card is not BD Ready and no sign of CPU Hardware Acceleration, despite it being turned on. It also says the software version being run by the graphics card is 8.6 when I am using the latest 9.4. I did try 9.2 as well.

I have poured througha all the forums but found nothing, so hope I have given you what you need to help me :(

What am I doing wrong??

  OTT_Buzzard 13:55 02 May 2009

From memory, the HD4850 has sound processing capability - disable this in Device Manager.

Also keep your onboard sound disabled.

Its worth trying your X-Fi in a different PCI slot.

Other than that, uninstall all of the software and drivers and reload everything. I'm not sure on what the pointer error means, but sounds like it should be a cock-up in a registry entry somewhere.

What monitor do you have?

  TinkyTime 14:14 02 May 2009

Thank you Buzzard, that was quick!

I found the ATi sound entry, a single line under sound, video and game controllers. I have disabled it and restarted.

Bluray Disc Advisor still says the same problems exist.

Have tried to play a Blu Ray disc again and same error appears :(

I wont put the X-Fi back in just yet - i know the onboard works well with blu ray. I know as things stand that its just a graphics card issue (I think!).

I have done two clean installs and exactly the same problem.

Hmmm any other ideas?

  OTT_Buzzard 14:37 02 May 2009

It's not likely to be a graphics card compatibility issue as the HD4850 does support HDCP. More liekly to be your monitor....what monitor do you have?
I'm assuming you are using a DVI cable, not VGA?

  OTT_Buzzard 14:45 02 May 2009
  TinkyTime 16:12 02 May 2009

Well the monitor is an ASUS VW222H 22" wide screen. The Monitor plays Bluray via the GeForce card no problem, and the Blue Disc Advisor shows it as fine, UNTIL that is I install the HD4850 at which point the monitor and card both fail the BD Ready test.

I checked that forum link, thanks for that. I am sure that i have clean install here. I didnt use drive cleaner, but i did use Windows Install Clean Up...

What do you think to that?

  TinkyTime 16:15 02 May 2009

Forgot to mention... my experience is different to the comments in that forum, I cannot get Blu ray to play at all, the application simply says Invalid Pointer.

I did get the freeze after a few minutes like he described, with the Geforce in and the X-Fi, but removing X-Fi and turning on the integrated solution solved that.

  TinkyTime 17:33 02 May 2009

Oh, silly me, i forgot to mention, its a DVI to DVI cable i am using. Sorry about that.

I did a fresh install like he suggested in the other forum but still the same problem (and thats with the 4850 sound on and off).

I dont know where to turn now...

  OTT_Buzzard 18:09 02 May 2009

A few other things to try (if you haven't already):

Check for updates to PowerDVD
Update ATI drivers to latest level
Update motherboard drivers

As a matter of interest, is this the only PC that you have the PowerDVD software installed on, or has it previously been installed elsewhere?

  PO79 19:21 02 May 2009

click here something here may help

  TinkyTime 20:51 02 May 2009

Thanks PO79 I have a look at that and whilst there are no errors similar to mine, there are a few things for me to look at just in case.

OTT_Buzz - I have tried the first two without luck. I have updated the P6T Bios but to no avail, so will check all the other drivers.

I will report back tomorrow!!

Thanks for you help so far. If anyone else has any ideas, do let me know.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique