Gems83 14:19 12 Jun 2008


I have Sky Broadband and was using a Belkin G+ USB adaptor, this was working fine until a week or so ago, now it is as if the PC can not pick up the adaptor even though it is installed an plugged in?

In the tray at the bottom there is an icon of a screen with a red cross through it and when I click on it there is a message saying a 'network cable is unplugged' and when I click on the Belkin icon on the desktop it is saying that the adaptor is not plugged in - but it is??

I tried buying a new adaptor thinking it was maybe a faulty one but still having the same problem!!

I am unsure whether this can be fixed mysekf or whether there is something wrong with the PC!

Any help would be greatly appreciated!


  Forum Editor 07:47 13 Jun 2008

uninstall the adaptor, shut down your computer, and then restart it without the adapter plugged in. Then plug the adapter in and watch Windows recognise it. Depending on which version of Windows you're using you may find that a driver is automatically installed, but if that doesn't happen you'll need to insert the software CD that came with the adapter.

If that doesn't work it's just possible that the USB port on your computer is damaged, but I suspect a driver issue.

  Gems83 07:51 13 Jun 2008

Thanks. I had previously tried uninstalling the adaptor and then just re installing it again but hadn't tried plugging in the adaptor before re installing like you have suggested.

I will try this when I get home tonight and fingers crossed this will work.

If this doesn't work and it is a damaged USB port I assume this can be fixed by an engineer? I have cover for my PC and can get someone out to fix it or get a replacement if need be.

  tullie 15:44 14 Jun 2008

Try something else in the usb port.

  Strawballs 01:04 15 Jun 2008

It could be the adapter that has died. click here

  Gems83 08:04 16 Jun 2008

I tried this at the weekend but still having the same problem, I tried my camera and i-pod in the USB and these were both picked up!? I am wondering if I should try a different adaptor, could it be that the Belkin one is no good on my PC? Or do you think there could be a paroblem with the router?

  brundle 09:25 16 Jun 2008

Do you remove and insert the adapter often? I've seen instances where a device will not be picked up properly if it's not plugged in to the same port that was used when its driver was installed. Not a problem for some hardware, but it is for others.

  Gems83 09:38 16 Jun 2008

I had the adaptor plugged into the same port the whole time it was up and running. It's only been since I have had problems that I have tried it in different ports and it doesn't seem to make any difference.

  brundle 12:16 16 Jun 2008

Using a laptop? There are few things to go through here click here, first being #4;

Then check Device Manager to see if the adaptor is showing up as an Unknown Device - there are two links to follow with advice.

  Gems83 12:23 16 Jun 2008

It is a deskyop computer, is this still applicable?

  brundle 12:24 16 Jun 2008

Yes. The `hibernation` bit isn't that important either, just the trouble-shooting steps.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

HomePod review

Comment regarder les Oscars 2018 ?