Headphones microphone not working properly with computer

  Abominator 13:22 12 Sep 2014


I'm having this really weird problem with my new computer. When I plug in my ae2i headphones something strange happens with the microphone. It seems as though it makes the volume control buttons the microphone... Talking/shouting into the microphone doesn't work, but when I click either of the three volume control buttons a sound from that button comes off. The volume meter for the microphone turns green and when I check "listen to this device" I can hear the click sound from pushing the buttons. However, I can't hear myself talking into the actual microphone. I've tried plugging it into both the front and back jacks, nothing worked. The headphones work on other computers just fine, but for some reason not on this one.

I tried other headsets like this, with a volume control button, and same thing there, it recognizes the buttons as the mic. I'm at a loss for words and have no idea as of what to do.

I don't have a separate sound card so I'm using the built in sound from my Gigabyte Z97M-D3H motherboard.

Please help!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Brilliant (and Weird) World Cup 2018 Art and Design Projects

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?