HDD not found.

  hardtofind 19:47 05 Jun 2011

Hello all.

I am running Win XP pro SP3. My HD is a Maxtor 160GB IDE drive which is shown as C. No problems with that.

I have installed a Seagate Barracuda 500GB SATA drive in the second bay. This drive is not 'seen' by the computer in Device Manager, BIOS or anywhere else. I removed it again and put it in an external caddy and it was recognised immediately. While it was in there I formatted it as it is a brand new drive. I assume therefore that the drive is OK.

I have now put it back in the main computer but again it is not 'seen'.

Can anyone throw any light on this please? I suppose it is just possible that the SATA cable is defective and I have ordered a new one.

I should mention that I did have a SATA drive in there before as a secondary drive and that worked OK. While ago though.

Thank you in advance.

  Jollyjohn 19:58 05 Jun 2011

Check power to the drive.

Check, in BIOS, that SATA control is enabled

Check BIOS settings to ensure a second hard drive is installed.

  chub_tor 20:06 05 Jun 2011

Also check your bios, make sure your sata controller is set to ATA, not AHCI. Otherwise the computer wont see the drive when trying to install XP in some cases.

  hardtofind 20:12 05 Jun 2011


How do I check the power? Also I have been in BIOS but cannot see a 'SATA control' There are 4 entries for a SATA drive and they are all set to auto, if that's what you mean. Only the IDE drive shows up.


Can't see any entries relating to ATA or AHCI.

  chub_tor 21:57 05 Jun 2011

Can you post the model number of your motherboard so that we can find the manual and take a look at the BIOS details? If you don't know the motherboard model you can find it by downloading and running SIW or Belarc

  Jollyjohn 09:09 06 Jun 2011

There should be a separate power cable to the drive.. Try a different one if possible.

  canarieslover 10:14 06 Jun 2011

Is your motherboard only 1.5Gbits SATA. I believe there is a jumper on the Seagate drive to limit it to 1.5Gbits instead of 3.0Gbits so that it is compatible with the earlier specification.

  hardtofind 15:43 06 Jun 2011

Thanks for the replies everyone and sorry for the delay in replying, just logged on.

chub_tor. My MB is an Asus M2N-E-SLI.

Jollyjohn. There are two spare ones and I have tried them both. No change.

canarieslover. I don't know the answer to that one. I didn't know there were any jumpers on a SATA drive but I will take it out again and check.

  hardtofind 16:43 07 Jun 2011

Thanks for the posts everyone.

I have now discovered the problem and feel really stupid. After taking the drive out and checking the cables again I realised that the power cable with the SATA power connectors on was not actually attached to the PSU. It was just jumbled up with the other cables. Didn't have a spare power connector so had to pinch one off one of my CD drives.

Anyway all OK now and sorry to waste your time.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best Amazon Echo: What’s the best Alexa speaker?

Kano Computer Kit Complete review: A fun DIY 'laptop' that teaches kids to code

Best pro photo editors for Mac 2018

TV & streaming : comment regarder les Jeux olympiques d’hiver 2018 ?