Have I lost System Restore ?

  yorky925 12:48 18 Aug 2003

While rectifying my last problem it appears that I have discovered another.

When attempting to use system restore I receive the following message

The procedure entry point RemoteAssistancePrepareSystemRestore could not be located in the dynamic link library WINSTA.dll.

Any assistance would be greatly appreciated. I am of course using Windows XP home.

  jazzypop 14:09 18 Aug 2003

First, try to disable System Restore, then re-enable it - this often does the trick.

"1. Click the Start menu -> Run. Type "sysdm.cpl" (Without quotation marks) in the Open field. Click OK.

2. Click the "System Restore" tab.

3. Click to check the "Turn off System Restore on all drives" box, and click OK.

4. Restart the computer.

5. Click the Start menu -> Run. Type "sysdm.cpl" (Without quotation marks) in the Open field. Click OK.

6. On the "System Restore" tab, remove the check mark from the "Turn off System Restore on all drives" box, and click OK.

7. Restart the computer again.

8. Check whether you can use the System Restore function.

Part II. If this issue persists, please perform the following steps to repair the System Restore feature:


1. In My Computer, click the Tools menu -> Folder Options.

2. On the View tab, make sure to check the option "Hide extensions for known file types".

3. Click OK.

4. Click the Start menu -> Run. Type "%windir%\inf" (Without quotation marks) in the Open field. Click OK.

5. Locate and select the file "sr.inf". Right-click it and then click Install."

Source - click here

ALternatively, ff you have a copy, reinstall SP1 - this should fix it.

  yorky925 17:30 18 Aug 2003

I tried No.1. Typed in sysdm.cpl then OK and got a box headed system properties. There is no reference to system restore.

Tried No..2. Got to stage 5 but could not find sr.inf could only find just sr and sr.PNF

What am I doing wrong please

  yorky925 17:39 18 Aug 2003

Sorry, should have mentioned I'm using Windows XP Home

  User-312386 17:58 18 Aug 2003

try a repair if XP

go to start>run now type sfc /scannow (note the space between the sfc and the /)

Make sure you have the XP disc to hand

  Wilham 17:59 18 Aug 2003

Sys restore only goes to highlighted dates (your choice) when installs were made or attempted. Is your XP a fairly new aquisition, could you have sent it back to square one? Are any dates on the Sys restore calendar highlighted (bolder)? Do you get the calendar screen at all?

  Wilham 18:07 18 Aug 2003

My query is if the winsta lib'y is empty because yu have emptied it.

  jazzypop 18:12 18 Aug 2003

You can check whether the System Restore Service has been disabled, or whether there are any specific error messages logged, by reviewing the advice at click here

You can also check your Registry entries at click here ( I do not recommend make any alterations to the Registry with regard to System Restore).

Note that you can also boot up with the XP CD in the drive and start System Restore from a command prompt - see click here

As stated above, installing SP1 is also very likely to fix the problem. Can you provide a link to the 'previous problem' that you mentioned at the start of this thread?

Finally, remember that you should have Task Scheduler enabled - see click here for a comprehensive discussion of System Restore

  yorky925 21:05 18 Aug 2003

Have tried every thing without success, am now totaly confused.
Have now sent for SP1 disc and hope that cures the problem.
Thank you all for your help

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

HomePod review

Streaming : Netflix ou Amazon Prime Video ?