Has Windows 10 killed my laptops?

  skyap 10:22 22 Sep 2016
Locked

I have two laptops and just before the free windows upgrade ran out I upgraded them both from Windows 7 to Windows 10. One was quite an old PC, maybe 8 years, the other only 4.

The newer one still would get about 5-8 hours battery out of it off a single charge but after putting on Windows 10 this kept dropping significantly. The older laptop didn't really hold it's charge all that long these days anyway. Then one day, the newer laptop made a noise like the power had been pulled and it went dead. I can't power it on at all, the battery isn't charging and I can't power it on even when plugged in. The next day, the same thing happened to the older laptop! It just seems to much of a coincidence that they would both die in the same way so close to each other, so is there a known issue with Windows 10?

Any idea how I can get these back up and running again without taking to a shop? I have read a few places that taking out the battery and power and holding the power button could help, then add power and turn on, but didn't work on either laptop.

Any help would be appreciated! I've gone from two laptops to none and wish I hadn't bothered with the 'upgrade'.

  Forum Editor 13:59 22 Sep 2016

Like rdave13, I haven't heard of that problem with Windows 10, and - like him- I wonder if there's an issue with the power supply. Have you checked the charger(s) are working OK?

  skyap 19:11 22 Sep 2016

I tried to reply earlier but the web page kept hanging!

Both the chargers lights are on and one of them fits a netbook I have so I definitely know it works. One of the laptops was plugged into a surge protector and the other a standard extension.

It's frustrating they don't even come on with just the power.the newer one sometimes has a green flashing led but it's differently from any patterns I've seen before and the charging light is orange. I'm presuming it's an error code so I'm trying to see if I can find anything about that.

Thanks for your replies.

  OCTCORE 21:24 22 Sep 2016

Have you tried removing the battery and holding the power button for 30 seconds, I don't why this would work but it did work for me once, also if you do get them working and they still have there factory images you could restore back to factory.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to Watch Honor 20 Launch Live Stream

The Best Game of Thrones creative projects inspired by the hit show

MacBook keyboard issues and other problems

Comment télécharger des films sur un iPad sans utiliser iTunes ?