Hard drive now not detected! Why?

  LucasJB 14:00 17 Oct 2008


Built a new pc recently, eventually after lots and lots of trouble...to cut the story short, my hard drive the other night was detected, worked fine, installed vista, and installed some games etc on. So I come back today to turn it on, and it says that my hard drive is not even detected in the bios? All i've done is a bit of wire management (i can assure you all wires are still plugged in!) and changed the monitor. On a previous motherboard it wouldn't detect it at all, any ideas why it isnt being detected?

Hard drive is:

Western Digital 500GB Caviar SE16 SATA II 300 7200rpm 16MB cache

Any help would be apreciated, I just want to play some god damn warhammer online....

  woodchip 14:27 17 Oct 2008

Could be Faulty Data Cable, but may be a dud drive

  Belatucadrus 14:28 17 Oct 2008

After the "Wire management" I'd assume it was a dodgy contact somewhere, either the cable or on the drive itself. Looks like you need to swap bits out until you pin down the culprit.

  LucasJB 19:29 17 Oct 2008

hmmm all i did though was move a few cables here and there until it looked tidy. replaced a sata cable - still nothing. id hate to buy a new hd to find it was completley fine and there was a dodgey contact. Powers defo going to it - my HD makes an annoying sound (has done since i had it) during boot up, then it shuts up. (it doesnt make this noise when we had it out of its housing) any ways to narrow down the culprit in this situation??

  woodchip 19:32 17 Oct 2008

If you moved them while running you may have blown the drive

  LucasJB 18:58 18 Oct 2008

never did it while running bud, that would be a hilariously terrible idea! :| all i did was install drivers for things, turned it off at the end of the night and then it hasn't booted up! theres no other possible reasons but cable or hd itself? originally had no boot up only fans whirring - turned out memory wasn't compatabile with new mobo, changed it, booted fine. i still haven't used my pc yet, its getting frustrated!!!

  Belatucadrus 01:14 19 Oct 2008

Have you tried booting from the Windows CD ?

  intense 10:39 19 Oct 2008

you didn't compress the files on your boot drive did you?

  LucasJB 14:36 19 Oct 2008

dont know how to compress them. we installed vista and all the drivers, played a game, turned it off and thats it. tryed using the boot disk, we've got to the install of vista again. will try that, maybe something was installed wrong :/

  Stuartli 14:50 19 Oct 2008

For some reason my MSI board's Bios began not to recognise my hard drive a while back (No drive detected), yet it all fires up as it should.

Like LucasJB it's a WD Caviar SE (320GB) which had replaced a 60GB version of the same model as I needed increased capacity.

  LucasJB 14:50 19 Oct 2008

okay, vista boot disk starts the install then asks which drive to install it in - it can see there being a cd drive in, cant find a hard drive to install in and see's a floppy - I DONT EVEN HAVE ONE!? anyone had a problem like this before?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)