Hard Drive not seen during OS install

  spras 19:28 21 Aug 2010

I'm trying to install Vista on to a new WD Caviar Green HDD but Vista won't recognise the drive. When I boot up I can see the drive in the BIOS but once I enter the Vista install process it can't be found. I know I need a driver - but which one? I'm using an Asus K8V Deluxe Motherboard. I downloaded all the drivers that looked relevant off the Asus website, put them on a USB stick and tried getting Vista to look for compatible drivers on it but it can't find any. Help please?

  northumbria61 23:13 21 Aug 2010

Try this - goto control panel\admin tools\computer management then click on disk management

Right click the bar for the new drive and select 'format', then just follow the wizard. This'll setup the drive so it can be used

  Ashrich 07:44 22 Aug 2010

Download the SATA driver click here , extract it to a new folder and copy it to a floppy , press f6 during the windows installation with the floppy in the drive ( borrow and external one if necessary ) and load the drivers when asked , that will sort out your problem .


  spras 14:35 22 Aug 2010

I gave that a go but it didn't work. Windows saw the driver and installed it (first time that's happened!), but the drive never showed up.

The mobo seems to have 2 different SATA controllers: A Promise controller and a VIA controller. I've plugged drives in to the Promise controller before without problems. When I plugged the drive in to the VIA controller to use this driver it throws up a couple of errors (BIOS doesn't see drive) and asks me to press g to continue - it might be meaningless in the long run but it makes me think I might have more success with the Promise controller where at least the BIOS can see the drive. Although I'm still at square 1 with this, Windows is refusing to co-operate

  Ashrich 15:22 22 Aug 2010

Which SATA ports are you using ? The ones next to the Via chip ( nearest the AGP port ) or the lower ones next to the Promise controller , I'm sure it would make a difference if the driver matched the SATA port the HDD was plugged into ie, Via driver for the upper ports , promise for the lower ones ,


  spras 15:53 22 Aug 2010

Yeah I've tried both, but I used the VIA ones to test the driver you sent. When it is plugged in to the VIA ports even the BIOS won't see the drive. When plugged in to the Promise SATA ports the BIOS sees the drive but not windows. I downloaded both Via and Promise drivers from the ASUS website although when I run the windows install it didn't consider any of them valid drivers for the hardware - presumably becuase ASUS doesn't seem to offer any support after Windows XP for this mobo

  Ashrich 23:01 22 Aug 2010

Do either of the raid/sata controllers need turning on or off in the bios by any chance so the other one can work ? Just a thought .....


  Ashrich 23:09 22 Aug 2010

I don't know this mobo but I think the promise controller is really a raid controller therefore needing at least 2 drives and needs to be set up in the bios , see if it can be turned off .

Just did a quick search about the above , click here , seems things can be turned on or off .


  kristain 07:10 23 Aug 2010

update the controller driver
urn hard drive diagnostic on the problematic drive. Download a free diagnostic utility from the hard drive manufacturer's support website

  spras 10:46 25 Aug 2010

Just about solved this through a lot of googling and a little luck...

VIA Controller continues to be completely uncooperative, so used the Promise SATA ports instead. I changed the Promise Controller to RAID mode (default is IDE) in the BIOS. Created a RAID 0+1 Array with a single disk. Downloaded the PDC20378 Fastrack - RAID - Driver (this driver won't work with Promise in IDE mode, hence the change), put it on a USB memory stick and installed it during the windows install process.

It's a bit of a hack, as I don't really want a RAID array but it shouldn't make much difference. Thanks for the help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

HomePod review

Les meilleurs logiciels de montage vidéo gratuits (2018)