hard drive not accessable

  jaimie 07:59 16 May 2010

I have a Lacie network drive which up until a few days ago worked perfectly. overnight it has become unavailable. My router can see it but can't connect to it. I have tried it on another network with the same result. So I have taken the drive out of the housing and installed it via SATA into my computer. My problem now is that the virtual disk service in Win 7 reports it as healthy but won't let me assign a drive letter to it so I can't access it. If i left click on the drive I only get the option to convert it to a dynaic disk, the option to assign a drive letter is greyed out. I'm desparate to get at the data I have stored on this drive, anyone any ideas please?

  BurrWalnut 09:15 16 May 2010

I‘m not hugely optimistic, but try going to Control Panel > All Control Panel Items > Folder Options > View Tab and make sure there is not a tick in ’Hide empty drives in the Computer folder‘ and further down, confirm that there is a tick in ‘Show drive letters’.

  kidsis 16:13 16 May 2010

long shot - could need to take ownership of the drive, access permissions may need to be altered while it is in your computer.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?