Hard Drive disappearance from My Computer

  [DELETED] 10:56 27 Oct 2003


I'm hoping that somebody will be able to help me with something thats puzzling me. I have a Pentium 4 1.4 GHZ PC running on XP with 512 MB of RAM. It has to Hard Drives: A 40GB C Drive containing my OS and Programs and a separate 160 GB Maxtor Hard Drive. The 160GB Hard Drive is/was partitioned into 4 parts.

When I turned my PC on yesterday, all the partitioned drives (with separate drive letters) had dissappeared entirely from the 'My Computer'. On start up, the drive is correctly recognised as the 'Primary Slave' and Device Manager shows the drive as working properly but I just can't see it (and about 80 GB of data!) anywhere.

Can anyone please help me find it as I would really rather not lose the data!

Thanks very much in advance

  [DELETED] 11:27 27 Oct 2003

Try, start>>run then type sfc /scannow (note the space between the c and /) make sure the XP cd is in the rom..

  graham√ 11:34 27 Oct 2003

With the PC off, check for loose cables.

  [DELETED] 11:49 27 Oct 2003

"On start up, the drive is correctly recognised as the 'Primary Slave' and Device Manager shows the drive as working properly"

Loose cables? bios recognises the drives. So I think Lozzy is on track

  [DELETED] 13:00 27 Oct 2003

do a virus check just to make sure

  woodchip 13:12 27 Oct 2003

This sound like an XP problem, not hardware as it can see it when you start up. so you can rule out cables and drive

  [DELETED] 13:49 27 Oct 2003

Download the Maxtor diagnostics from their site, should find it and sort it....

  [DELETED] 18:48 27 Oct 2003

Thanks for all your responses on this one. I have now tried the following (note, I checked all cables and fittings before I put the question on the board - as I thought I had better try the easy things first!:

I ran the 'sfc /scannow' utility and this came back fine (though it did keep on asking me to insert the Win XP and 'Whistler (?)' disks about 40 times even though it was already in!!

I ran Norton and that can back clear

I then ran the 'PowerMax' diagnostics program from the Maxtor sight, which firstly told me there was a 'partition read error' and then after it fully scanned the disk, it told me it could fix the problem and asked me if I wanted that. I clicked 'yes' and rebooted. The disk still has no drive letters but when I look in Disk Management, I can now see the disk - which is showing all its space as 'unallocated'.

I then tried to partition again, but right at the end, it told me it couldn't partition due to a 'read error'!! So I'm now back to square one! I still can't see if any of my data is left on the disk and I can't access it!! I guess all I can do now is take the HDD to PC World or somewhere like that and see if they can read it...

Please let me know if you have any further suggestions and thanks again for all the support so far.

  woodchip 18:51 27 Oct 2003

If you can get hold of Norton Disc Doctor That should fix it

  [DELETED] 19:05 27 Oct 2003

copy and paste the following into start/run


press ok,

see if you can get any sense out of it,if you right click on the partition there is an option to change drive letters, that might help assign drive letters

  [DELETED] 19:27 27 Oct 2003

I had a similar problem. I opened up my PC and found that some cables were loose.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi 8 Review

Adobe confirms it’s working on a full Photoshop for the iPad

Apple announces new MacBook Pros for 2018

Qu’est-ce qu’Amazon Prime ?