Hard Drive Capacity - Help!!!

  Alien463 12:46 02 Oct 2003

Hope someone can help out, this is driving me insane...

Have a compaq presario model 5146ea internet pc with 512mb ram running windows me.

Currently have a 60gb drive set to master, and am in the process of installing a second 120gb western digital hdd as slave.

After configuring jumper settings and other options, boot up the computer. Get a message saying that my configuration has been automatically updated (disk 1 60gb, disk 2 120gb, disk 3 cdrom, disk4 cdrom). So far so good.

Restarted the computer from windows me boot up disk to create primary partition on slave drive, choose yes to enable large drive support, change fixed drive to two, choose 1 to create primary dos partition or logical drive.

However, new partition information now shows that new drive has primary partition size at slightly over 23gb (23476mb), no way near 120gb expected size.

Any help would be much appreciated,
Thanks in advance,


  [DELETED] 13:20 02 Oct 2003

Have you went into the BIOS and tried setting it manually?

Usually you press DEL during the boot...enter the BIOS and look for the section that shows you IDE devices. They are normally on AUTO, click on your 120g drive and manually select the size, I had a similar problem a few months ago with a 120gig Maxtor and manually setting it did the trick.

  critic-al 13:27 02 Oct 2003

also Have you still got your master on the end connetion on the IDE cable?

  woodchip 13:31 02 Oct 2003

You want to be careful using fdisc on the second drive as you may have selected you old drive. You are better getting Partition Magic or what I use is Acronis Disc Administrator

  [DELETED] 13:32 02 Oct 2003

Do you really wnat a primary partition on your slave drive?. Should it no be an Extended DOS Partition in which you create logical drives of size of your own choosing. That way windows recognises all you drives in sequential order C; D: E: etc.

  DieSse 14:35 02 Oct 2003

FDISK with Win9X and ME has a problem with partitioning HDDs over 68Gb - there is an updated version here click here

This might be your problem.

  plankton 14:46 02 Oct 2003

You could also try downloading the "Install" and "Problem Solving" software from the Western Digital site.....

  Alien463 08:50 04 Oct 2003


Thanks for the advice,

Download Data Lifeguard tools from Western Digital Website, and worked perfectly.

Thanks for all posts,


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?