Hard drive in caddy will not format

  dangerusone 10:05 24 Jun 2012

I have a hard drive taken from a PC that died on me (motherboard failure) I put it in a caddy and connected to my new Pc and tried to format it. When trying to format it the Drive letter came up as "C" which it was on the old PC, my new Pc has the same drive letter and I was afraid I would damage my new Pc so I cancelled the formatting. I went to computer - manage - Disk management, and tried to assign a new drive letter but not successfully Drive G. this flashes up intermittently. Is there anything I can do to formatt this hard drive.

  johndrew 10:22 24 Jun 2012

You should be able to assign a new identity to the (now external) drive unless for some reason your PC is recognising it as a 'primary' drive, have a look at this article it may help.

I would suggest that you identify positively the drive in the caddy, right click it and 'delete' it. This should remove the header and allow you to format it fully.

  Fruit Bat /\0/\ 10:49 24 Jun 2012

sowing as C: because it will be seen as a System disk

your normal C: drive should be shown as disk 0, is the new c: online

other should show as removable select the romoveable one and delete the system files (XP? - NTLDR NTdetect boot.ini) this will stop it being seen as system disk.

  dangerusone 12:10 24 Jun 2012

johndrew, I looked at the How to -- article link but couldn't get anywhere.

FruitBat, my normal drive is showing as C, I managed to alter the caddy drive as D but it is flashing and is not showing long enough to Partition/Formatt

I must admit in some of these explanatory articles I find some of the terminology hard to follow, old age I guess.

  robin_x 12:17 24 Jun 2012

Try MiniTool Partition Wizard or Easeus Partition Master, you'll have to google for them, sorry.

Right click the partition, Change Letter, Format etc

  dangerusone 13:00 24 Jun 2012

In Easeus Partion Master it is only showing one drive as follows - Disk 1/Basic 465.76GB/System NTFS 100MB/C:OS NTFS 453/F:HP Recovery NTFS 12.33GB, The DVD drive is showing but the caddy drive D? is flashing on and off too quickly to do anything with it.

  Fruit Bat /\0/\ 13:44 24 Jun 2012

What size drive 3.5? is this and externally powered caddy?

  dangerusone 00:16 25 Jun 2012

Fruit Bat

500GB but showing as 453GB and the caddy is a Pluscom SATA to USB 2.0 external powered,. Reading from the instructions, no driver needed except for Windows 98, I'm on Windows 7.

  lotvic 00:42 25 Jun 2012

Have you tried putting it in a different usb port on your pc?

  dangerusone 12:18 25 Jun 2012

I have tried various USB ports,even tried an old powered USB from the days when PCs only had about 2 ports with no luck.

Where do I find a spare SATA port, inside the case? if that is so it's a bit beyond me.

I think I'll give it up as a bad job, there are no files/photo's on it that were not backed up. I was just messing around seeing if I could do it.

I think maybe my new PC is getting confused because it is basically seeing 2 drives named C which is what it was before it was taken out of the old PC.

  Fruit Bat /\0/\ 13:23 25 Jun 2012

500GB but showing as 453GB that's normal should show approx 465GB the rest may be a hidden partition for tools/ image etc.

The sata ports will be on your motherboard probably 4 of them with sata0 used for your hard drive. and sata 1 for the DVD drive.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro (2019) review

Inside the redesign of the world's largest computer games platform, Steam

Apple Streaming Service Release Date & Apple TV Subscription Rumours

Quel antivirus gratuit choisir pour un PC ?