Hard disk sometimes not available.

  MuDelta 16:28 10 Oct 2007

I installed a hard drive from an old computer in my present machine and until recently it has worked without problems but now, more often than not, it is reported as missing when the machine starts up. When they drive is “not available” and I run an AVG virus scan it begins by reporting that the partition table (MBR) has changed. When the drive is available, this message does not appear. I therefore assume that the message is in some way related to the unavailability of the drive.

My master drive has a SATA connector and the second one is PATA and its jumpers are set as the slave.

How can I stop the erratic unavailability of my second drive?

  woodchip 16:46 10 Oct 2007

try setting jumper to master

  MuDelta 18:14 10 Oct 2007

Hello Woodchip

That seems to have done it. I have shut down and restarted six or seven times and my old drive has been available each time.

I thought that having two drives set as master caused conflicts but there has been nothing so far.

I will delay marking the prob. as resolved for a little to be sure that erratic behavior has really stopped but it looks very promising.

Many thanks.


  woodchip 19:18 10 Oct 2007

Sata does not work on the Master Slave like IDE drives

  MuDelta 15:42 11 Oct 2007

I think I can say that it is OK now. Thanks woodchip.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?