Hard disk problem (BSOD)

  tomme91 14:35 28 Dec 2014

so I get BSOD on random occasions. It happens the most when my pc has just started up. These are the errors i've got on my BSOD. (mostly with kernelinpageerror at the top)

BCCode: f4 BCP1: 0000000000000003 BCP2: FFFFA8005A71910 BCP3: FFFFA8005A71BF0 BCP4: FFFF80002F83270 OS Version: 617601 Service pack: 1_0 Product: 256_1

I updated all my drivers but i still got BSOD with "Kernelinpageerror". I also tried system reset to a time when i didn't got BSOD but after a while it happened again. The temperature of my GPU and CPU are both very good.

Next, I ran a CHKDSK check. these are the results. CHKDSK is verifying files (stage 1 of 5)... 214016 file records processed. File verification completed. 638 large file records processed. 0 bad file records processed.
2 EA records processed. 44 reparse records processed. CHKDSK is verifying indexes (stage 2 of 5)... 274782 index entries processed. Index verification completed. 0 unindexed files scanned. 0 unindexed files recovered.
CHKDSK is verifying security descriptors (stage 3 of 5)... 214016 file SDs/SIDs processed.
Cleaning up 82 unused index entries from index $SII of file 0x9. Cleaning up 82 unused index entries from index $SDH of file 0x9. Cleaning up 82 unused security descriptors. Security descriptor verification completed. 30384 data files processed. CHKDSK is verifying Usn Journal... 36597288 USN bytes processed. Usn Journal verification completed. CHKDSK is verifying file data (stage 4 of 5)... 214000 files processed. File data verification completed. CHKDSK is verifying free space (stage 5 of 5)... 64407186 free clusters processed. Free space verification is complete. Windows has checked the file system and found no problems.

312466431 KB total disk space. 54413412 KB in 159195 files. 97896 KB in 30385 indexes. 12 KB in bad sectors. 326367 KB in use by the system. 65536 KB occupied by the log file. 257628744 KB available on disk.

  4096 bytes in each allocation unit.

78116607 total allocation units on disk. 64407186 allocation units available on disk.

Internal Info: 00 44 03 00 97 e4 02 00 d7 72 05 00 00 00 00 00 .D.......r...... 42 01 00 00 2c 00 00 00 00 00 00 00 00 00 00 00 B...,........... 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................

The name of my hard disk is a Samsung hd322hj I use only 50gb/300 gb because i only use my computer to play 1 game.

Anybody here that can help me solve this problem ? Do you think my hard disk is broken and i should just buy a new one ?

  tomme91 14:37 28 Dec 2014

wow, i'm sorry for the bad overview. I wrote this in a other program

  Fruit Bat /\0/\ 15:42 28 Dec 2014

Its probably a memory fault but Bluescreen view or who crashed will give you more inf

  Secret-Squirrel 09:25 29 Dec 2014

".........These are the errors i've got on my BSOD. mostly with kernelinpageerror).........12 KB in bad sectors.........Do you think my hard disk is broken "

It's possible that your hard drive is the cause of those BSoDs as they're frequently caused by Windows being unable to read data from the page file because the disk has bad sectors.

To get a second opinion, use a disk tool that can read the drive's SMART info. If you don't have one then Passmark's free DiskCheckup is a good choice - you can get it from here. When it's installed, make sure the correct disk has been selected (if you have more than one) then click the "SMART Info" tab and post back all the details for the "Reallocated Sector Count" section for me to look at.

  tomme91 12:52 29 Dec 2014

SysInfo DLL Version: SysInfo v1.0 Build: 1041 Time of export: 13:49:04 29-dec-2014

Device information:
Device ID: 0 Interface: SATA Device Capacity: 305242 MB Serial Number: S17AJ1NQ800225 Model Number: SAMSUNG HD322HJ Firmware Revision: 1AC01113 Partitions:
C: 305142 MB

ATA information:
Disk geometry:
Cylinders: 38913 Tracks/Cylinder: 255 Sectors/Track: 63 Bytes/Sector: 512 Total disk sectors: 625142448 Logical sector size: 512 Physical sector size: 512 Media rotation rate: N/A Buffer size: 16384 KB ECC size: 4 Bytes

Standards compliance:
ATA8-ACS Supported: No ATA/ATAPI-7 Supported: Yes ATA/ATAPI-6 Supported: Yes ATA/ATAPI-5 Supported: Yes ATA/ATAPI-4 Supported: Yes World Wide ID: 50000F0000082052

Feature support:
SMART supported: Yes SMART enabled: Yes SMART self-test supported: Yes SMART error log supported: Yes LBA supported: Yes IORDY supported: Yes CFast supported: No DMA supported: Yes Maximum Multiword DMA mode supported: 2 Multiword DMA selected: None Maximum UltraDMA mode supported: 6 UltraDMA selected: 5 Maximum PIO mode supported: 4 SATA Compliance: Yes NCQ priority information supported: Yes Unload while NCQ commands are outstanding supported: No Phy Event Counters supported: Yes Receipt of power management requests supported: Yes NCQ feature set supported: Yes SATA Gen2 Signaling Speed (3.0Gb/s) supported: Yes SATA Gen1 Signaling Speed (1.5Gb/s) supported: Yes Software Settings Preservation: Supported, Enabled In-order data delivery: Not supported Initiating power management: Supported, Disabled DMA Setup auto-activation: Supported, Disabled Non-zero buffer offsets: Not supported Trusted Computing supported: No Host Protected Area (HPA) supported:

  Secret-Squirrel 16:14 29 Dec 2014

Thanks for that but unfortunately it doesn't give the information I asked for. Did you inadvertently download the wrong program or are you using one of your own? If it's the former then use the green "Download Now" link top-right of the page I linked to earlier to get a copy of DiskCheckup.

Here's a screenshot that shows the program window and an example of the "Reallocated Sector Count" information I asked for.

PS: Sorry but I don't respond to e-mail requests - this thread is the best place to discuss your PC problems.

  tomme91 19:24 29 Dec 2014


Here is the screenshot of the "reallocated sector count"

click here

  Secret-Squirrel 20:02 29 Dec 2014

"Here is the screenshot of the "reallocated sector count""

Ah, I wasn't expecting that. Windows says your drive's got three bad sectors but the drive itself says that no bad sectors have been detected and remapped.

At this stage it would be helpful to see some further details of the BSoDs you've received so download BlueScreenView as suggested by Fruitbat, run it, and take another screenshot. Make sure that "Bug check string", the first two parameters, and "Caused by Driver" are all clearly shown in your screenshot.

Or, if you have access to a file-sharing website, go to your C:\Windows\Minidump folder and upload two or three of the latest .dmp files - those are the files that Windows creates when it suffers a catastrophic failure (BSoD). I'll then run those crash-dump files through the more advanced WinDbg program to see if I can come up with a diagnosis.

I'll look back in the morning and see if I can give you a better idea as to what's causing those crashes.

  tomme91 14:52 30 Dec 2014

these are the 3 latest .dmp files !

click here put the details of my BSOD here later bro!




  Secret-Squirrel 18:19 30 Dec 2014

Here's some of the technical info for your three BSoDs:

CRITICAL-OBJECT-TERMINATION (f4) A process or thread crucial to system operation has unexpectedly exited or been terminated. Several processes and threads are necessary for the operation of the system; when they are terminated (for any reason), the system can no longer function.


KERNEL-DATA-INPAGE-ERROR (7a) The requested page of kernel data could not be read in. Typically caused by a bad block in the paging file or disk controller error.

ERROR-CODE: (NTSTATUS) 0xc000000e - A device which does not exist was specified.

DISK-HARDWARE-ERROR: There was error with disk hardware.


KERNEL-DATA-INPAGE-ERROR (7a) The requested page of kernel data could not be read in. Typically caused by a bad block in the paging file or disk controller error.


DISK-HARDWARE-ERROR: There was error with disk hardware.


Because you say that most crashes are of the KERNEL-DATA-INPAGE-ERROR type, here's what Microsoft have to say:

0xC000009D, or STATUS-DEVICE-NOT-CONNECTED, indicates defective or loose cabling, termination, or that the controller does not see the hard disk.

0xC000000E, or STATUS-NO-SUCH-DEVICE, indicates a hardware failure or an incorrect drive configuration. Check your cables and check the drive with the diagnostic utility available from your drive manufacturer. If you are using older PATA (IDE) drives, this status code can indicate an incorrect master/subordinate drive configuration.

It certainly looks like your hunch of a hard disk problem is correct but I can't say with any degree of certainty that it's actually the disk that's faulty. It could just as easily be a faulty or loose cable, faulty disk controller or motherboard problem. If you've got a spare disk drive lying around then by all means clone your system and install it if the Microsoft advice above doesn't help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Frida Kahlo's life, art and legacy explored in Google's new giant online collection and app

Best Android emulators for Mac

Comment importer des contacts d’un iPhone à un autre iPhone ?