Half Life 2 won't work on DVD ROM drive

  Unlucky Bob 00:23 18 Nov 2004

I inserted my eagerly awaited DVD ROM disc of Half Life 2 into my Drive and I can't get it to run. The message comes up 'Windows cannot read from this disk. This disk might be corrupted, or it could be using a format that is not compatible with windows.'

The DVD ROM drive I have is a Toshiba SD-M1712.
I must admit, this is the first PC DVD Rom game I've bought. Am I doing something wrong?

Any help would be really appreciated..

  Smegs 00:27 18 Nov 2004

Can you try it in someone else's DVD??

  Unlucky Bob 15:41 18 Nov 2004

Sorry to take time to get back to you. I don't have access to another dvd drive at the moment but I've put another DVD rom disc in the drive and that installs games just fine. Any thoughts?

  lufc1953 15:48 18 Nov 2004

Same problem on my sons computer This disk might be corrupted, I uninstalled something called steam from add and remove restarted the comp and it installed ok, I think steam was from another game not too sure but half life needs to install it.

  mattyc_92 16:10 18 Nov 2004

I have recently answered this type of problem so... go to click here for more help (soz if this link doesn't work, copy and paste the link if the link is not active)

  Unlucky Bob 16:28 18 Nov 2004

I tried uninstalling steam. That hasn't worked unfortunately. I've checked that the device is working properly and it would appear that all is well in that direction.

Could it be that the disk is corrupted and I've just been unlucky in getting one??

  mattyc_92 16:36 18 Nov 2004

Yes that is a possibility.... Try using "BadCopy Pr" on this disk. You can recover EVERYTHING from the disk onto your computer and burn it back to another disk. Go to... click here for this great little application

  Unlucky Bob 17:58 18 Nov 2004

Thanks for your suggestion.I tried BadCopy Pro. The prog says that there are no recoverable files on the disk...

I guess I'll have to send it back and try a replacement copy. If that dosen't work, then who knows???

  mattyc_92 18:00 18 Nov 2004

Your drive may just be messing around. Try going to the driver's manufactor's website for help with this

  Unlucky Bob 18:20 18 Nov 2004

I've already gone down the driver route. Toshiba only have dos drivers on their website (I think thats what they are). Otherwise they use generic drivers from microsoft. I've also just put it into a friend's laptop where it worked just fine....

This is getting worse and worse. I've emailed vivendi technical support. I'm hoping they may help..

  mattyc_92 18:25 18 Nov 2004

The only other thing I can think of is that one of the cables inside the CPU that links the drive to the motherboard may have came lose

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)