Half-done XP installation & IPX gaming

  Malaclypse 19:51 15 Aug 2003

Arrrggg... I really don't have much luck with computers!

I'll try and ask this in the clearest way possible, but I'll probably confuse everyone.

1. I tried to repair Windows XP professional. Mistake.
Helpfully Toshiba didn't provide a proper XP disk with the laptop in question, just a ghost disk which I didn't want to use. They left the i386 directory on the C: drive though....
Couldn't run winnt32.exe because of some dll being missing, so I got out an old 98 boot disk, and booted up the PC from that.
I then entered i386, and ran winnt.exe

I'm looking for a repair option. It seems as though it's gonna do a complete install. It seems to have frozen - the HDD light is on, but I hear absolutely no noise. After some time I switch it off.

Now when I boot up I have the dual-boot options of "Windows XP professional" (which still works), "Previous OS on C:" (which gives "Invalid System disk" regardless of whether a floppy is in the drive) and "Incomplete XP installation, continue" as the third choice.

As it stands, I can't see how to get rid of these two extra options.
The "installation" one gets me to a INSTALL/REPAIR thing, but I wanted an auto-repair like Windows 2000 had, not some console I can't use.
The INSTALL option complains about the lack of a EULA (why? I don't know) and quits out.

So I'm stuck with these two extra boot up options which are annoying me.

2. The root of the problem which made me do this: IPX protocol on Windows XP.

I've been trying to get several games working over the network, and the IPX protocol just refuses to work on one PC.
I can do TCP gaming, but that doesn't work on a few of my disks (incidentally the better games!)

The one I've been using to test the network is Need for Speed III, as I know it works.

Basically, I try to host an IPX game, and it says "Failed to connect"
It displays a similar message on other games.

When I try to host an IPX game on my other XP computer, I get the full screen of options etc - but it doesn't appear as a 'game i can join' on the (faulty) PC.

I've tried changing the Frame type and number of the IPX protocol on both machines, and have unbound them from any clients or file sharing, but I still get this same message.

It has been suggested to me that it could be some network logs clogging it, but this seemed a mite unlikely to me.
When I got a fatal "Blue screen and shut down" error whilst altering some IPX properties I got a bit worried (This is XP after all!).
After that, even Need for Speed III started occasionally giving Ddraw errors and refusing to start - and that was after clean reboots.

So I decided to see if XP had an auto repair function, and now i'm into a sticky mess...

can any one help on either issues (but preferably the first?!)



  jazzypop 21:06 15 Aug 2003

1. click here to edit out the two 'rogue entries' at bootup.

2. Uninstall Need for Speed

3. Uninstall the IPX networking protocol.

4. Reinstall the IPX protocol (select your network adaptor then choose Add Protocol)

5. Reinstall Need for Speed

Make sure that you do not have any firewalls (including the built-in XP version) blocking your network gaming

  Malaclypse 22:39 15 Aug 2003

Thanks Jazz,

After a while, I figured that out: I found that XP has a "System Restore" utility in the 'System Tools' menu.

Thankfully, yesterday lunchtime I got a Windows Update download and therefore XP made a 'recoverable save point' - so I restored XP to the exact state it was in yesterday!! and to my utter surprise it solved not only the boot up problem but another couple of things that had been bothering me since last night
(Not that this was ideal - I did a fair bit of configuring to my network since lunchtime yesterday!)


The IPX thing: Have done what you said to no avail.
It's not just with Need For Speed that it's happening, it's with any IPX network game. TCP works fine, but on many games that isn't an option.

Nevertheless, have uninstalled and reinstalled in the order you mention and I'm still getting the same error.

"Failed to connect"...

Have used msconfig to disable the firewalls on both machines, and made sure windows InternetConnectionFirewall was turned off - that's one of the first things I tried lol ;o)
Pretty confident they're not at fault.

It's strange: The one Pc is able to host an IPX network game, yet the other is confronted with the 'failed to connect' message when trying the same thing.

Yet they're both using the same protocol, same OS and as far as I can see they're using the same setup: except the (faulty) PC gets it's IP addressed assigned by the DHCP on the (non-faulty) one, which is static.
I don't think that TCP should really be affecting this, and I need it in this situation so that I can share a net connection.

Any more suggestions would be great, but it's still kinda problematic.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Social Media has Propelled Political Graphic Design and Art in the Last Decade

The best kids apps for iPhone & iPad 2018

HomePod d’Apple : date de sortie, prix et fiche technique