Had Infinity installed, but have lost wireless conection to printer.

  algey 23:05 16 Mar 2013


Never had a problem with my wireless connection(Canon MP 620)to my Acer Aspire 7736. But in the last few days have had BT Infinity installed and when trying to use the printer get the message 'Printer not responding.' Don't understand why having Infinity installed should affect this wireless connection. I'm using Windows 7.

Hope there is a simple answer to this !


  rdave13 00:00 17 Mar 2013

If it's a wireless connection you will need to reset the printer to search for a new connection. Apply the security key and away you should go.

  onthelimit1 09:17 17 Mar 2013

Yes, as the router, I assume, has been changed, the key will be different.

  algey 18:21 17 Mar 2013

Hi dave and onthelimit

Understand what your saying and have tried to get the printer to search for another router but keep getting error messages. Also tried re-installing the printer software and following the on screen directions but still no luck. Looks like I wii have to get in touch with Canon.

Thanks for taking the time to reply.

  rdave13 18:37 17 Mar 2013

Troubleshooting PDF here.

  algey 19:26 17 Mar 2013

Have a paper copy of the trouble shooting, but when following instructions never get the 'access point' page on the screen to allow me to type in the info. required,why I've no idea. I'm sure it's me as my computer skills are pretty basic. Will give it one more try.

Again, thanks for your time.

  chrisjohn 21:23 17 Mar 2013

im having same problem my hp printer worked a treat with sky broadband ...changed to infinity now it just drops connection,may be due to home hub having smart channel scan ? also the bt tech toldme wireless printers dont like the hub.

  Nontek 22:40 17 Mar 2013

I have two Epson wireless printers working perfectly through my BT Infinity HomeHub.

  algey 23:27 17 Mar 2013


Look at the time of the post! Got there in the end by ignoring the warning ' this driver has compatibly problems please contact Canon'.

Kept going because you made it sound simple. Perhaps it was!

chrisjohn, best of luck.

  Secret-Squirrel 08:59 18 Mar 2013

"............also the bt tech toldme wireless printers dont like the hub."

That's been my experience too. I've also encountered problems with Smart TVs and BT Home Hubs.

Apologies for hijacking the OP's thread but you may be interested to learn that you don't actually need a Home Hub 3 for Infinity. Any cable router that supports PPPoE such as this one will work and you simply connect it to your Openreach modem. If you're interested and need the Infinity connection details then just ask.

  Janetsmith 08:55 21 Mar 2013

Also having problem connecting new HP 6520 printer to the BT Infinity with Homehub 3. Started by trying the one button easy setup, no go, then tried by entering the appropriate codes of the Hub, still nothing. Finally tried using cable connection & followed instructions to swap to wifi, still won't work. Please can anyone help, I'm going crazy!!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?