Graphics Card Issues - No display no power.

  NerdTree Billy 17:01 30 Jul 2018
Locked

Hello everyone. I am in a bit of a state right now. My graphic card an AMD R7 370 4gb seems to have stopped working. This happened just after I factory reset windows. Now windows will not register that the card is installed when looking at the driver menu. Only loading the integrated card. I have tried card in other machines however still nothing. When the HDMI or DVI cables are plugged in at start up. A message on my monitor states that there is no input signal and goes into standby. Other cards do seem to work. The fans on my R7 370 are not spinning but the light on the GC is on but we have determined that this light is powered by the motherboard. This suggests the card is not getting power from the PSU but having tried it on other power supplies. The card seems to be the issue. Having inspected the boards there is no visible damage such as burns, melting or dampness. The screen will output through the integrated HDMI but my graphics card will not load.The only setting in my BIOS that relates to the graphics card is a plug and play option which is enabled. The graphics card is a 6pin card. It is most likely that the card is the issue however I would like to know if anyone has any idea how to fix the issue or have encountered similar problems in the past.

Thanks for your help in advance.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Fold review: Hands-on

How to create a robot painting in Photoshop

iMac 21.5in (2019) review

Comment faire pivoter une vidéo ?