GPU is not being used over intergrated graphics

  Icarus97 11:56 11 Oct 2015
Locked

My graphics card (MSI NVIDIA GTX 970) is not being used over my integrated graphics. The card appears to be attached as you can see it turn on and the fan spins on start up (although stops when Windows boots, I'm assuming because it switches to integrated graphics)

Whenever I attempt to boot a game it either immediate stops working or states that my PC does not support DirectX 11 features.

When I attempt to go to the NVIDIA control panel to switch my preferred graphics options, the following error appears:

"NVIDIA Display settings are not available.

You are not currently using a display attached to an NVIDIA GPU"

However, when I go to NVIDIA GeForce Experience and then to "My Rig" it appear to recognize the card, stating I have a 970.

I have tried uninstalling the drivers, restarting, then reinstalling them twice with no luck.

I have also tried system restoring to a point where my PC apparently "Installed Direct X" with no luck, even though I'm certain I already had it installed.

Looking up help online tells me to select my graphics options from the BIOS, but when I try to access it during start up, I cannot. When the PC turns on, the display is either not working, or is pitch black (I used to receive an ASRock splash screen where I could access the BIOS) Rather, it just immediately boots to Windows.

I find it bizarre that this has suddenly happened from a working PC, the only real change I have made is that I set up a new speaker system (which I have since detached in an effort to make it work)

I did also install two new driver updates from GeForce Experience, I doubt the problem comes from that however, as the problem would be wide spread. Also, when I system restored it removed the updated drivers and reverted it back, yet it still didn't work

Any help would be greatly appreciated, I'm extremely desperate.

  Jollyjohn 13:59 11 Oct 2015

Shutdown the PC and remove the graphics card. On boot immediately start tapping the key to get into BIOS. Change to using graphics card first, save and exit. If Windows boots, great, shut down and add graphics card. If not then use Alt+F4 then Down arrow then Enter to shut down PC. Add graphics card and try again.

  rdave13 14:30 11 Oct 2015

I know it's a bit like teaching grandma to suck eggs but are you connected to the card socket and not to the motherboard's gpu socket?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Officially Launches In The UK

Artists FriendsWithYou reimagine Snoopy and Charlie Brown for a Peanuts London takeover

iPad Pro 12.9in (2018) review

Les meilleurs smartphones chinois disponibles en France