Google Earth graphics problems

  FreMar 12:32 31 Mar 2013

O/S: Windows XP Home Edition Service Pack 3. 2.93 gigahertz Intel Pentium 416 kilobyte primary memory cache, 1024 kilobyte secondary memory cache. Intel 82915G/82910GL Express Chipset Family 915/910G graphics card.

I’m having problems with the free version Google Earth graphics. The program worked perfectly ok a few days ago. I have followed all the support help guides; have done a restore to when it last worked ok, have done a complete uninstall and reinstall, checked both the DirectX files and my graphics card for updates, but it still won’t work correctly.

If I open it in OpenGL mode I get a black globe with only a black and white map like aerial view terrain, and it is difficult to pin point the area I want, but the ground level graphics are perfectly ok. If I open in DirectX mode, the globe and aerial view are in colour, and I can see the area I want to zoom into ok, as they should be, but then the ground level graphics have annoying flashing grey squares that move about at random over the chosen view. Is there anything more I can try? I am not having problems with any other program graphics other than this one.

  Ex plorer 15:20 31 Mar 2013
  Nontek 15:27 31 Mar 2013

I have had the same problem in the last few days, as has a close friend of mine, so I think it might be possible that GE has some sort of problem itself!

I cured mine by completely un-installing GE using Revo uninstaller, and then re-downloaded and re-installed GE. Seems to be working fine at the moment.

  Nontek 15:28 31 Mar 2013

PS - my friend is using XP, I am using Win7!

  Ex plorer 15:30 31 Mar 2013

Try this also Goggled your problem and there are a few answers out there you may find use full.

  FreMar 18:18 31 Mar 2013

Thanks to all for the advice. I have unistalled several times using Revo Unistaller, and then reinstalled again each time, but got the same problems. I even tried an install from an older version setup that I had saved in a folder on my desktop, but that gave all the same problems. I assume that version updated automatically when I next connected to the net. Maybe GE will right its self eventually??.

  Nontek 18:44 31 Mar 2013

Just tried my GE - NOT working again! I am going to uninstall it and just rely on my Samsung Galaxy S3.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

HomePod review

Les meilleurs logiciels de montage vidéo gratuits (2018)