Google Earth Flight simulator

  Simsy 17:22 26 Sep 2007


I understand that the latest Google earth has a flight sim built in...

I also understand that to get to this feature you need to press Ctrl+Alt+A...

When I do that absolutely nothing happens?

I have tried starting Google Earth in each of DirectX and OpenGL mode, to no avail.

WinXP Home. Google earth itself runs fine, and I can "fly" bu titlting and moving the map, so I don't think it's a graphics card issue. (Radeon 9200 256Mg)

I don't have a joystick, but I don't think that's the problem either, as I've seen the keyboard short cuts, as issued by google, to make it work.

Any suggestions?




  alB 17:26 26 Sep 2007

click here ...alB

  chris-the-womble 17:27 26 Sep 2007

Hi Simsy,
When I tried it the other day, it took me a few presses of the shortcut (Ctrl+Alt+A) in slightly different sequences (i.e. one slightly after the other). Not sure if this will work for you but you might want to give it a shot anyway.
Sorry if this is no help.

  Snec 17:45 26 Sep 2007

On mine it is under 'Tools' (at the top) then, unsurprisingly, 'Enter Flight Simulator'

  Simsy 18:36 26 Sep 2007

I discovered on another site;

click here

That there is a bug for us UK folk... Changing the language settings away from UK made the key combination work, and also added the option "Enter Flight Simulator" to the tools menu. (As per Snec's post above. It wasn't there before, I had looked).

Changing language settings back to UK leaves this available on the tools menu.

So that's that sorted.

Now all I have to do is learn to fly!!



  Technotiger 19:37 26 Sep 2007

Don't forget you air-sickness tablets!! I love flying, but my room is still spinning LoL ...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?