General Error Epson 1290

  Diemmess 17:53 20 May 2011

Aged friend has Epson 1290 printer which was OK up to today. Now on switch on, flashing green main button printer will not complete initialising cycle.

With his 89 years and failing sight plus crackly phone I think I understand him to say in answer to my questions ---

Green wont stop flashing. Paper wont load. When talked through Control panel to the test page same thing, though a red light shows as well (I believe). Pop-up note saying General Error STOP OK. The screen then tells him to turn off, remove all clips, torn paper etc, delete print queue and restart. I suspect he may need new ink cartridges. He has used lookalikes from the beginning, but though I have had most of these errors myself over the years (currently with an 870 very similar but A4 printer) I am not sure where to begin with his problem.

Searching the net for answers I see SSC service freebie is often quoted, but I would rather take some simple course if you experts know of one?

  SparkyJack 20:48 20 May 2011

SSC may well be an answer- certainly worth a try. All so after a certain number of pages have been printed- a 'Service required'may flash up.

This indicates the absorption pads need changing.[or cleaning]much has been written here on this topic'- use the search panel

But as it is a software message it may not be needed as such - but the need to reset the counters. To do this SSC has the option or by switching off the machine. holding down a combination of buttons and switching the machine on whilst the buttons remain held down for a number of seconds. The exact combination of button varies with models. A good place to seek further help

link text

  rdave13 20:56 20 May 2011

To be honest, the printer has survived well I think. Could be a foreign object fallen in to the printer or everything's worn out? Have a look here.

click here

  Diemmess 15:55 21 May 2011

Have brought the 1290 home to meddle in peace.

  1. However I start the printer appears to go through normal initialisation and the stops with flashing red and green lights alternately. This is "Unknown Error contact dealer."

  2. As suggested, downloaded and ran SSCservice.exe to reset the counter. Absolutely no change.

Have looked all over the net for down to earth details on how to change (access) the waste ink pads. Many instructions for other printers but everyone says it is difficult but no one (free) offers an answer! I have had the hood off and all laid bare before me but there appears to be a serious bit of work to get at the ink pads.

Finally the unknown error could be a terminal warning and if so I'm wasting my time, the owner is almost reconciled to replacment, but if anyone has succeeded in replacing the waste pads on a 1290 please tell me how, or this goes for recycling.

  woodchip 16:39 21 May 2011

Best way it Remove Software and Drivers first from Add Remove in Control Panel, Then check Printer Folder to see if its Removed the Printer if not, Delete it. Then do a Search both in windows and Regedit for Epson And delete all that it finds, then unplug Printer, if its not been unplugged Reinstall Software and drivers until windows starts looking for Printer then plug it in and turn it on

  Diemmess 17:08 21 May 2011

Thanks woodchip, but you have misunderstood what I have and haven't done. I've brought it home where I can fiddle in familiar surroundings. It installed on my own computer without fuss...... it will not complete initialising stopping at the Unknown Error- Inform Dealer.

I've tried the SSC reset counter with no difference. The printer should of course be able to run its own in-house routines but just persists with the basic error instead of becoming one steady green light.

I think it is dead, but wanted to give it one last chance with a clean waste receiver and a reset. Unlike later printers the foam stuff is right in the depths of the printer and unless I can learn how to dismantle it (Epson 1290) without serious damage....... I'm stuck.

  rdave13 17:17 21 May 2011

I think it's an old printer and has reached the end of its life.

  Diemmess 20:17 21 May 2011

Yes rdave13, this is what I think too. Will let thuis tread run in case anyone can offer a suitable How to - replace those pads.

If I can do that I can wash and replace them. Don't mind the effort but expect the worst.

  woodchip 23:17 21 May 2011

If you have fitted a External Waste Tank you do not need to clean the Pads, just use the SSC tool to reset it. As long as he she knows, to use the Waste tank

  rdave13 23:33 21 May 2011

Nothing to do with the pads I think. Spray the whole lot with wd-40 lubricant and maybe some parts will move. If it works then it will only last a short time. A new printer will be the answer.

  Diemmess 09:13 22 May 2011

For everyone who has tried to help-

There is no obvious mechanical failure. On switch-on, the usual movements take place. If I pull the power plug while the printhead is outside its resting place I can then slide the block left or right without a hitch. It will recover normal position when power is returned.

However it it is started, in diagnostic mode or normally, after a few seconds, no more sounds or movement, normal position with flashing red cartridge light and green power light.

SSC service reset applied, not a jot of difference. This is more and more like the dead parrot sketch....... the printer has passed on and the corpse will follow to the recycling centre!

Grateful for your posts.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Why this awful City of Los Angeles job ad for a graphic designer is actually brilliant

iMac Pro review

Les meilleures prises CPL (2018)