Frequent GPU/CPU usage/clock drops with new GPU

  froomus 19:18 31 Jan 2019

Hi,

Since I added an RX-570 into my PC I've been getting massive GPU and CPU usage drops as well as the clock speed of both dropping (all at the same time) whilst playing fairly new 3D games. Games such as Forza Horizon 4 and The Witcher 3 will run fine for the first 10 minutes, but then the problem starts occurring every 10-40 seconds or so and will make games stutter extremely badly when it does. I'm not sure if it's a problem with cooling, or if maybe my CPU is bottle-necking my GPU. The temperatures seem to be fine - the CPU reaches a max of 70 degrees, and the GPU gets to around 55 (with the fan at around 85% speed). It could also be the fact that I got a fairly cheap ASRock motherboard that really isn't meant for gaming. My old graphics card ( a 750ti ) would never get drops like this...Please could I have some suggestions as to what to do? I have attached a screenshot of the CPU clock speed while gaming below...

Specs:

. RX-570

. i5-3470

. 8gb DDR3 - 1600mhz

. 500W EVGA psu

. ASROCK h71m dg3 Mobo

Thanks : )

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

MWC 2019: Xiaomi, Samsung, Huawei, Nokia, LG, Sony & Microsoft

Illustrator Owen Davey on how he's created a successful series of animal-themed children's picture…

WWDC 2019: Dates, what to expect, and how to get tickets

Battlefiled 6 ou Battlefront 3 pour 2019 ?