Freecom DVB-T USB Stick problem

  [DELETED] 15:32 02 Apr 2006


Even the Freecom tech support are stumped and have told me to send this product back to Amazon and get a refund, but I refuse to be beaten!

The stick works fine on my laptop so I know there is no hardware fault. The problem is on my PC running Windows XP Home.

When I plug it in the yellow balloon pops up recognising a new USB device and begins the add new hardware wizard. However, the computer fails to find the drivers on the CD. Even when I copy them to the harddrive or download new ones it just won't pick them up. I even point it to the exact location or exact file and it still won't recognise them.

Any ideas greatly appreciated.


  Stuartli 15:41 02 Apr 2006

You have to install the software and drivers first (USB device).

You should be prompted when to connect the Freecom unit.

  [DELETED] 16:09 02 Apr 2006

I have tried installing the software first but the drivers are installed indepedently of the software. At no point during installation am I prompted to plug in the stick.

Any other ideas?

  [DELETED] 16:42 02 Apr 2006

Try installl the direct x first if on the softare disc, then plug the usb in and install the driver(don`t instal through found new hardware wait for the disc set up on screen) then install the DVT-B

  [DELETED] 16:51 02 Apr 2006

I installed direct x first, then plugged the usb in and it automatically went to the found new hardware wizard. This is where it can't find the drivers. There's no standalone executable from which to install the drivers though I think this is what I need! So still not working.

Any more idea guys?

  [DELETED] 17:03 02 Apr 2006

Check on device manager, that there are no drivers installed.

If there are, then uninstal them.

Start again by restarting PC, instal drivers/software, before plugging in.

When it says found new hardware, click to let it install automatically.

This is the usual way to do it.

  [DELETED] 17:07 02 Apr 2006

Cheers, but I'm an IT teacher so I've done all the obvious things, that suggestion included.

There must be an answer that's going to involve something a bit more technical, but I'm stumped as to what it could be!

  [DELETED] 22:35 03 Apr 2006

have you checked that you have usb2 on your desktop.this item will only run with usb 2.If you are not sure try disconnecting from the mains for a few minutes.this worked for me .

  [DELETED] 23:05 03 Apr 2006

Nope, I have USB2 and tried the mains disconnection trick.

Any other ideas anyone?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple