Foxit Amazon 'corrupt not PDF' problem

  spuds 12:27 21 Jun 2012

On the computer I have Adode and Foxit installed, and both seen to work well as alternatives. Amazon website is used daily, and I have just started to have a problem when pages or descriptions are opened on the site.

A Foxit error message box appears and informs that the page is corrupt and not pdf. Click on the OK in the box, and the error box goes away, then returns again, with the same message. Click OK and the box goes away again, and the page opened can be used freely. Another page, same exercise.

Question, does anyone use Foxit with Amazon, and are having the same problem?.

Abode appears to have no problems with Amazon pages.

  lotvic 14:14 21 Jun 2012

Sounds as if in your browser you have wrongly associated some type of page to open with Foxit

In Firefox it is in Tools > Options > Applications. (click on the one you want and then a dropdown arrow appears which has menu for actions to take)

  spuds 18:45 21 Jun 2012

lotvic, thanks for the suggestion.

Just had a look in Firefox, and Abode is ticked as the default, so in theory I assume, Foxit shouldn't have anything to do with the Amazon pages.

Or have I got this wrong?.

  lotvic 20:00 21 Jun 2012

I'm puzzled why either should have anything to do with Amazon pages.

Can you post a link to an Amazon page and say where you click on it that causes Foxit to open and give you an error message?

I have Foxit so will see what happens when I do it.

  jellyhead 20:38 21 Jun 2012

I am having the same error message box come up on this web site when I open some pages.

  lotvic 20:52 21 Jun 2012

Apparently it is a bug if you use Firefox 13, and can be fixed by updating Foxit

quote from foxit forum: Please update your Foxit Reader to version and it should fix this problem

  lotvic 20:56 21 Jun 2012

I tried to post a link to the foxit forum but pca wouldn't let me. So just google for: Foxit error message Firefox 13 -and it should be the top answer.

  jellyhead 22:13 21 Jun 2012

That appears to have fixed the problem, thanks Lotvic.

  spuds 22:50 21 Jun 2012

Thanks again lotvic for your help, just downloaded the upgrade and it seems to have resolved the problem.

  lotvic 01:31 22 Jun 2012

Glad it's sorted, and for me too when I move to Firefox 13 on this pc :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Sam Falconer transforms science and geology into digestible, elegant illustrations

HomePod review

Les meilleures séries Netflix (2018)