Found new hardware wizard repeating

  JMTaylor 23:00 12 Feb 2005

I have seen the previous articles but my Laser printer keeps needing this wizard on startup. There is a so called fix in article 298370 of the Microsoft Knowledge base. This tells me to delete a line in the registry. Unfortunately when I try it tells me that it won't let me delete this file.
I have XP Pro, SP2,and its a Kyocera printer. I've tried uninstalling and reinstalling but to no avail.
John T

  Totally-braindead 23:14 12 Feb 2005

My Epson inkjet was doing it for a while, I'd loaded the drivers from the Epson disk and for some reason every thime I switched the printer on Windows would think it was a new printer and come up with the Add New Hardware Wizard, the solution was to let Windows install its own driver first and then once that was done to install the updated Epson software and then change the default printer leaving the Windows driver there. I hope this makes sense to you, it worked for me.

  JMTaylor 17:44 18 Feb 2005

I've tried the fix that MS suggest but the required registry entry cannot be deleted. Kyocera say it's a problem with XP SP 2 and they can't help. I seem to have to work round this.

  GaT7 18:26 18 Feb 2005

click here for trouble deleting registry keys. A comprehensive solution for WinXP is at the bottom of the article. G

  Totally-braindead 14:55 19 Feb 2005

I take it my suggestion disn't help?

  JMTaylor 17:50 19 Feb 2005

sorry, Totally-braindead. no it didn't. talking to Kyrocera it seems to be a common XP SP2 fault. Thanks anyway for the message.

  Diodorus Siculus 17:52 19 Feb 2005

What happens if you let the wizard run through all the way?

  fred 20:32 19 Feb 2005

I had a very similar problem with my printer. Windows kept looking on the web for the driver. Denying access to the web sorted it for me.

  JMTaylor 00:15 20 Feb 2005

On startup the found new harware looks for 3 similary named kyocera printers - i have only one. I have removed as much reference to Kyocera from the registry as I dare and downloaded the latest drivers. The wizard starts up and asked me to define a driver from a list. whatever i do it then says it cannot find some file or other or asks for a disk that is not the driver disk.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Meilleurs drones (2018)