Floppy problems!!

  Newuser2162 21:15 22 Nov 2003

I recently replaced my faulty motherboard, Socket A with AMD Duron 700, a bit antique I know but it does what I need, except the floppy drive. All others bits as before running Win98. In explorer & my computer I get A:\ is not accessible or The disc in drive A is not formatted etc. If I leave a disc in when booting I don't get the Non system disc message. Light shows on the drive so it has power & I have checked the data cable, appears OK.
Does anyone have any suggestions please?

  Jester2K II 21:21 22 Nov 2003

Is the light on all the time? If so, open the case and turn the floppy cable over. One end is plugged in wrong!

  Legolas 21:22 22 Nov 2003

If the light on the drive is on all the time then your cable is wrongly fitted or the drive is faulty, check the cables are fitted the right way round.

Have you tried a cleaning disk in the drive, you would do well to blast it through with some compressed air ( although yo could buy a new floppy drive for about the price of a can of compressed air).

  Newuser2162 21:39 22 Nov 2003

Thanks, the drive light is not on all the time, only when it is trying to read a disc

  woodchip 21:43 22 Nov 2003

Is the floppy enabled in the BIOS

  Stuartli 09:01 23 Nov 2003

My son, an IT support specialist, told me not so long ago that the main problem with floppy drives are incorrectly inserted or faulty cables/leads.

A cleaning agent is not necessary as all drives, including CD/DVD and rewriters, are very well sealed.

Using one may do more harm than good, particularly the wet types.

  Stuartli 14:37 23 Nov 2003

By one of those remarkable coincidences, although in this case a DVD rewriter, my son's two-month-old Pioneer 106 began to play up today and would not burn disks.

Tried the usual quick checks first and then decided, before a definite decision to return it, to replace the cables.

It now works exactly as it should....:-)

As he says, amazing how cables go faulty, even though they don't move.

  AndyJ 15:50 23 Nov 2003

My workplace had exactly the same problem with several PCs not so long back. All of them required new motherboards - could be you replaced your old motherboard with a faulty "new" one.

  Newuser2162 20:49 23 Nov 2003

Woodchip - Thanks, The floppy is shown in the Standard CMOS setup (AMIBIOS) and in Features Setup the onboard FDC is enabled, I cant see anywhere else that it could be. I have checked the cables again and relaced the data cable, still no different.
AndyJ - Its being so cheerful that keeps you going I suppose. Thanks anyway.

  woodchip 14:04 24 Nov 2003

Right click on "My Computer/Properties/performance/File System/Floppy” make sure there is a tick in the box to search for floppy when you boot the computer

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?