Floppy drive failure

  nugget 11:41 31 Mar 2003

Recently I have been getting a "disk not formatted" error whenever I try to access a floppy. I have changed the drive for one I know works, changed the ribbon cable, again for one I know works. Checked the disks on another PC (all access ok). Removed the controller etc from the device manager and re-booted. All to no avail. The system is recognising the floppy drive and seems to be accessing it ok. Am running Win98 and to check to see if it was a problem with the OS, I re-booted with a bootable startup disk in the drive, which it ignored (bios set to boot from 1. FDD 2. CDROM 3. HDD) and booted straight from the hard drive. I don't know what else to try or what is causing it. Any ideas?

  Megatyte 12:28 31 Mar 2003

Check in BIOS that your floppy is set to 1.44Mb.


  DieSse 13:48 31 Mar 2003

Norton Anti-Virus can cause errors with accessing floppy drives, if it's set to check the floppy on access for boot sector viruses. You can disable this.

  nugget 15:29 31 Mar 2003

Megatyte - Checked the BIOS and it is set at 1.44Mb.

DieSse - Do not have Norton Antivirus installed.

Any other suggestions?

  lemon2 15:42 31 Mar 2003

Have you tried cleaning the drive?

It's often neglected, and gets all kinds of dust in there. Especially if like me, you've several chassis fan operating.

  961 17:22 31 Mar 2003

1) Faulty connector on motherboard?

2) Virus of some sort?

  Switcher 19:15 31 Mar 2003

Have you tried a different floppy drive in your PC to determine if the problem is drive related or system related.

  woodchip 19:31 31 Mar 2003

Check for 5+ volts at the power plug that connects to the floppy disc red wire. or if there is a spare connector try that on

  nugget 00:19 01 Apr 2003

Thanks for all the suggestions, will try them out and let you know how it goes.

  lionheart766 11:11 01 Apr 2003

Had this prob myself a while ago. Turned out to be the floppy disk was being slightly obstructed by the case when inserted and wasn't going into the drive fully(the case is one where the floppy pokes through a "letterbox" type opening), remove the floppy drive from the case and try it .

  siouxah1 17:17 01 Apr 2003

Have a machine with a similar problem.

Eventually came to the conclusion that the drive channel on the motherboard was 'duff'.

Now have a boot CD on hand for this one and dispensed with the floppy.

Regards Brian j

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?