[DELETED] 00:10 11 Mar 2006

I have been running FS 2004 with no problems for the past year. Suddenly some of my saved flights started crashing the programme so I decided to do a re-install. F**k me, no matter what I do I cannot get the re-installed programme to run. It goes through the initial splash screen and then just stops and brings me back to my desktop. I have tried everything, making sure the installation folder is clean, directing the installation to another folder, making sure the registry is clean, dumping add-on programmes and making sure of no hang-ups in the registry from these. I am completely stumped on this 'COMPLETELY'. I have invested in a high end graphics card for this game, plus extra memory and now the bloody software won't run. I would really welcome some help here.


  [DELETED] 00:29 11 Mar 2006

No need for language, even if you hide some of the letters...

Any error codes? I assume it's win xp? Have you updated graphics drivers or rolled them back if you updated them previously? Checked for patches for the game?

  [DELETED] 00:34 11 Mar 2006

Have you also loaded all updates and patches to the Sim?

Make sure you also have the latest graphics card drivers and motherboard chipset drivers installed.

Are you running any distributed computer programs?.....Some of those can have an adverse effect on games.

Might be worth Googling your graphics card in connection with the game to see if there are any known issues there too.

  [DELETED] 13:18 11 Mar 2006

Tried all of the above, still no success. There has to a DLL problem or something like that. There are no error codes, the game throws up the splash screen,then I can see an attempt to re-size the screen ( by the mouse pointer ), everything goes black and I get returned to the desktop.The event viewer shows three errors associated with each failure and each one simply states that it cannot source the fault and to refer to help files for assistance. I think this calls for a complete re-install of Windows XP, something I totally hate having to do.

Thanks for your assistance so far.

  [DELETED] 13:29 11 Mar 2006

Have you updated FS9 to version 9.1 with the official MS patch. If so you will need an updated FSUIPC file from click here go to the free downloads section. This should be placed in the <root>\program files\MS games\FS9\modules folder, taking care to rename the existing FSUIPC.dll file to FSUIPCold first.

  [DELETED] 14:09 11 Mar 2006

I haven't upgrade to 9.1 so I don't imagine that is the problem. This program was running fine until I had to a re-install due to occasional crashing.

  Mike D 14:45 11 Mar 2006


This happened to me and the solution was to reinstall FS2004. As with you, I had not made any changes that would account for the problem. Any addon software should be left untouched by the process, but I did find that the odd scenery package (VFR) also had to be reinstalled.

Once the process was completed everything worked fine.

You might find the forums at click here of help to you.


  [DELETED] 15:02 11 Mar 2006

Any of these help click here

  [DELETED] 23:08 11 Mar 2006

Okay everybody, problem solved and you are not going to believe this!! I am running IE7 Beta 2- the official download from microsoft. However, there are issues with FS 2004 that they have failed to address ( and yes they wrote both programs). Having used some of the tips you posted here ( thank you ) I managed to get FS 2004 running but with a lot of errors and crashes. On investigation I realised that all the crashes involved 'mfc70.dll'. When I did a search on the net I found that by going into the FS2004 root directory and deleting 'OLEACC.DLL' all conflicts with 'mfc70.dll will stop. And it is all down to IE 7 Beta2. Thanks for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Microsoft Surface Book 2 15in review

Illustrator Amy Grimes on how setting up her own eco-brand led to success with clients too

MacBook Pro keyboard issues and other problems

Test : l’enceinte connectée HomePod d’Apple