Flash Memory (problems with Belkin)

  [DELETED] 23:23 27 Dec 2003

Have just received a USB Flash Memory (128Mb) Mass Storage Drive for Xmas.

The kit comprised : The portable (small cigarette lighter sized) drive + software CD-Rom. The plug & play idea seemed attractive...Windows ME and above (I have ME OS) won't need any special software, take it with you and hey presto!...According to the blurb. No such luck!

Having printed off the PDF instructions and followed what were some pretty confusing directions - (when you should plug it in, when you should reconnect, now follow set up and then "place CD Rom in drive"..when you already should have done that to get the set-up wizard anyway!!) - my PC kept crashing, at one point BIG TIME necessitating a reboot from the Start Up disk 'cause it'd lost a .INI file!!!

I've tried every approach conceivable and have now uninstalled the programme out of pure frustration. Either I'm over looking something quite simple OR things aren't up to scratch on the Belkin front!

Any ideas anyone?


  [DELETED] 23:29 27 Dec 2003

in my experience i have found that xp/me does a far better job of recognising plug and play devices than bundled software, sorry i should rephrase that, the os should simply recognise the device as as a mass storage device and it shold pop up in my computer and file dragging and dropping becomes available

  [DELETED] 23:31 27 Dec 2003

ignore me lets start from scratch

have you tried simply plugging the device in? if so what happened?

  [DELETED] 23:52 27 Dec 2003

Thanks jonnytub

If I simply plug the device in, the PC recognises summit's connected and I get a pop up window which reads WINDOWS HAS FOUND NEW HARDWARE & IS LOCATING THE SOFTWARE FOR IT. Along with this I get a request (via my Firewall) to access the internet. I deny the request 'cause I can't see how this will help...I have a CD-ROM with associated software and even when this is in the CD-drive it still requests internet access?

After denying the request it goes off and then the same message pops up again....again, I deny the request and the window disappears and that's it!

If I now look at my DRIVE window it does at least show removable drive F: but if I try then to drag/copy anything into it it won't let me. It comes up with a message saying that the removable drive has not been formatted do I want to do that?

I have tried formatting it but the system simply freezes. I've left it for some time to see what happens but nowt. A reboot is the only answer.

Any further attempts to click on the F: Drive result in a BLUE screen!!!!

It's all quite bizarre.

  [DELETED] 14:10 28 Dec 2003

Try contacting Belkin support tomorrow, Monday.


e-mail: [email protected]

or, fill out an on-line tech: support form here:

click here

Their driver site is here:

click here=

  [DELETED] 14:16 28 Dec 2003

Thanks A

that's exactly my plan...I'll also check out the latest drivers just in case


  [DELETED] 14:18 28 Dec 2003

I had a similar problem which I traced to the Soundblaster Live/Audigy Disc Detector Utility, which failed to detect the USB disk properly. I disabled Disc Detector from the Control Panel Icon and all was well.

  [DELETED] 14:44 28 Dec 2003

have you tried shutting down your firewall before you install/plug it in?

I've had this before with zone alarm.So now when anything is added I always shut down AV & firewall

  [DELETED] 20:15 30 Dec 2003

Thanks Jim, Anchor & Christmas Cracker...sorry, been off line for a couple of days.

Will try the stuff you suggest. My father's PC is exactly the same as mine (MESH) - we bought at the amse time, same spec etc...

When I plug the Belkin in to his machine it detects the thing and puts the removable disc icon up in the system tray (which is more than it'll do with mine). All is well until I try then to copy files to it. I keep getting a window saying the device is write protected and to un-write protect it in order to save. There is a small slide switch on the side of the device with OPEN & CLOSE padlock indicators...it's on OPEN so can't see why it won't allow copying? I tried moving the switch to the other position...just in case...but the same again.

At leat it appears to be triggering the disc-detect on my father's machine but it's still not happy.

  [DELETED] 09:12 31 Dec 2003

If the good advice given is unsuccessful, please let me know via [email protected] including your serial/order number and screen name. I will have an engineer contact you to discuss this further.


Mesh Support

  [DELETED] 09:27 31 Dec 2003

Thank you Davey - much appreciated, will do

Happy New Year

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How to watch the World Cup for free on TV and online

Meet Superfiction, the little design studio with a load of character

Best Mac music-production software

Comment savoir si votre message a été lu sur Facebook & WhatsApp ?